2005 Reporting Services - Multiple Worksheet data starts on second row in Excel.

  • Corey

    Old Hand

    Points: 311

    Hi guys,

    I am running SQL Server 2005 Reporting Services sp 2. When I create any 2 tables on a report, eliminate vertical spacing between them and insert a page break after the first table or before the second table, the second sheet's data always starts on the second row. All of the data is in tact but the sheet begins will a very small (vertically speaking) empty row and the data is displayed starting in row 2. I have tried removing padding, eliminating borders, adding/removing page headers, I have removed vertical spacing, tried using metric and US units but nothing works. I even started a new report and just added 2 small tables with a couple of rows of data and nothing else but still row 1 remains empty on the second sheet. I have searched for a fix and a few other people have come across the same issue but there doesn't seem to be a solution. Our client is very firm on this requirement so if there is no solution I will have to do this another way. Thanks in advance for any input.

    BTW, I am setting up a subscription to render and send this report via email. It also does not work when I export to excel from the Visual Studio preview tab.

    Corey

  • suri.yalamanchili

    SSCommitted

    Points: 1645

    Have you tried the visibility option?

  • Satu

    SSC-Addicted

    Points: 463

    Hi,

    I don't know if the SSRS version is of importance here - I'm using SSRS 2008. Anyways, I initially had the same problem with all extra sheets beginning with an empty row. Then I eliminated almost all the space between various tablixes (in my case, a tablix forms an excel sheet). For example, the first tablix's height is 1.2 cm. When the second tablix's location from the top is eg. 1.201 cm, no empty row appears. It seems that enough empty space between components is interpreted as empty excel row.

    BR,

    Satu

  • alex.kentoyo

    Newbie

    Points: 7

    I am using SSRS 2008 and have the same problem, the only solution that I know right now is to slightly overlap the tablix in the design view - it doesn't look very appealing in the designer but at least the result looks right 🙂

    hope that helps

  • elizabeth.soleas

    SSC Rookie

    Points: 36

    Select Tablix Properties > Page Break Options > Add a page break before in all tablixs after the first one (do not select a page break option on the first tablix). Also, set Position > Location to 0,0. This works for me.

  • gurmeetxsingh

    Newbie

    Points: 6

    Thanks ! It also worked for me as well .

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic. Login to reply