• In the Cube Drillthrough Options screen, on the Columns tab, you should see all of the columns contained in all of the tables used in your model. Assuming you have only 2 tables, a fact and a single dimension, the columns may be something like


    fkCol1 tblFact

    fact1 tblFact

    fact2 tblFact

    pkCol1 tblDim1

    Desc tblDim1

    Assuming that you have run the optimise schema, the model will now not have a join between tblDim1.pkCol1 and tblFact.fkCol1

    What you need to do is on the Filter tab of the Cube Drillthrough Options screen, add a filter like

    "tblDim1"."pkCol1" = "tblFact"."fkCol1"

    So basically you're using the name of the tables to make the join/s in the drillthrough filter, you shouldn't be trying to use the (models') Dimension name, it won't work.