SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


How to resolve RequireKerberos value problem in sql 2008 failover cluster installation process?


How to resolve RequireKerberos value problem in sql 2008 failover cluster installation process?

Author
Message
v-yasu
v-yasu
Old Hand
Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)

Group: General Forum Members
Points: 325 Visits: 15
I set up 2008 sql failover cluster, at last the error message shows 'RequireKerberos is 1' value set to unexpected range...
I see no Kerbero configuration during the wizard, yet
hi_abhay78
hi_abhay78
SSCertifiable
SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)

Group: General Forum Members
Points: 5681 Visits: 386
we use Kerberos for better security .otherwise the default is NTLM .Not sure where the issue is .
Can you share the complete error message please ..that will be helpful .
If you get the error on the setup page , there will be a page icon .Click on that and paste the information on the notepad or direscly here ..

Awaiting your reply .

Abhay Chaudhary
Sr.DBA (MCITP/MCTS :SQL Server 2005/2008 ,OCP 9i)
v-yasu
v-yasu
Old Hand
Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)

Group: General Forum Members
Points: 325 Visits: 15
TITLE: Microsoft SQL Server 2008 Setup
------------------------------

The following error has occurred: There was an error setting private property 'RequireKerberos' to value '1' for resource 'SQL Network Name (33SQLCluster)'. Error: Value does not fall within the expected range.

For help, click: http://go.microsoft.com/fwlink?LinkID=20476&ProdName=Microsoft+SQL+Server&EvtSrc=setup.rll&EvtID=50000&ProdVer=10.0.1600.22&EvtType=0xDCFFB30D%25400X1251FB33

-------------------------------
BUTTONS:

OK
-------------------------------


I have looked at the linked resource but still no idea how to resolve such problem..
hi_abhay78
hi_abhay78
SSCertifiable
SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)SSCertifiable (5.7K reputation)

Group: General Forum Members
Points: 5681 Visits: 386
I have not seen your enviornment but i can certainly guide here .
RequireKerberos is the Dword registry value that ensures whether you are using kerberos authentication or not for a Network Name resource.if its 1 its enabled else its 0 [default].

So what i feel is ,In case you are using kerberos authentication check the resources that its checked in the check box (go to properties of the Network Name resource.)

Else you can go to the registry and change this value to 1 or 0 as per your enviornment need and if the setup gives you the option to retry , do it .Else run the setup again .If you do not have the permissions to change the registry keys let someone with that permission do that .

you can find this key under registry HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL.x\Cluster()

hope this helps

Abhay Chaudhary
Sr.DBA (MCITP/MCTS :SQL Server 2005/2008 ,OCP 9i)
kobayashi.yoshi
kobayashi.yoshi
SSC Veteran
SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)

Group: General Forum Members
Points: 257 Visits: 6
Hi

I had also same problem.
http://social.msdn.microsoft.com/Forums/en-US/sqlsetupandupgrade/thread/6ccf9380-852d-4b59-b128-97e0e870452c

So far still I couldn't find the solution.
I'll try to check the registry if I could solve this issue.
kobayashi.yoshi
kobayashi.yoshi
SSC Veteran
SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)

Group: General Forum Members
Points: 257 Visits: 6
Hi

I checked my registry.
Since the installation hadn'T complete due to this error,
no entry can be found in the registry.

I guess the problem may relate to Active Directry.
v-yasu
v-yasu
Old Hand
Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)Old Hand (325 reputation)

Group: General Forum Members
Points: 325 Visits: 15
Hi,
we can resolve this problem by using SQL slipstream, seems it was a bug with SQL 2008, slipstream integrate sp1 with the setup
media, and you can install the failover successfully without RequireKerberos problemSmile

Link:
http://blogs.msdn.com/petersad/archive/2009/03/02/sql-server-2008-basic-slipstream-steps.aspx
NOTICE:
[Need to search in C:\SP1 to find sqlsupp* and install the support file for slipstream of SQL 2008!!
Then SETUP.EXE /PCUSource=C:\SP1 will take effect ]
kobayashi.yoshi
kobayashi.yoshi
SSC Veteran
SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)SSC Veteran (257 reputation)

Group: General Forum Members
Points: 257 Visits: 6
Thanks yasu

It is solved now!
I have almost spend 3 days for this issue.
I tried more than 10 times just for intallation....
S. Kusen
S. Kusen
SSCrazy Eights
SSCrazy Eights (9.7K reputation)SSCrazy Eights (9.7K reputation)SSCrazy Eights (9.7K reputation)SSCrazy Eights (9.7K reputation)SSCrazy Eights (9.7K reputation)SSCrazy Eights (9.7K reputation)SSCrazy Eights (9.7K reputation)SSCrazy Eights (9.7K reputation)

Group: General Forum Members
Points: 9719 Visits: 1165
One other issue that I had related to this was that the SQL Server Network name set up with Kerberos enabled wouldn't start after the install completed. If you want to use Kerberos, your AD admin will need to create a computer object within AD under your SQL virtual instance name.

Took me a day to find that tick that was different than other clusters we had running.

I then re-produced the issue with my AD admin and decided to remove the Kerberos because we don't typically require it at my company.

Hope this info helps others in their SQL 2008 quests!

Regards,
Steve
trilist
trilist
SSC Eights!
SSC Eights! (859 reputation)SSC Eights! (859 reputation)SSC Eights! (859 reputation)SSC Eights! (859 reputation)SSC Eights! (859 reputation)SSC Eights! (859 reputation)SSC Eights! (859 reputation)SSC Eights! (859 reputation)

Group: General Forum Members
Points: 859 Visits: 719
That worked for me too.

Thank you for this post.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search