SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Cannot connect to a remote server


Cannot connect to a remote server

Author
Message
chrismiller
chrismiller
SSC-Enthusiastic
SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)

Group: General Forum Members
Points: 119 Visits: 141
Hi All,
I am not sure if this is a newbie question or not...
I have this website which allows me to use sql server. I cannot get it to connect to the remote server at all. First I used sms 2005 express, didn't work then i uninstalled it and installed sms 2005 developer edition and let it set all the defaults. I cannot for the life of me get it to connect to the remote server. Now the hosting company can connect to it. I keep getting this error...

An error has occurred while establishing a connection to the server. When
connecting to SQL Server 2005, this failure may be caused by the fact that
under the default settings SQL Server does not allow remote connections.
(provider: Named Pipes Provider, error: 40 - Could not open a connection to
SQL Server) (Microsoft SQL Server, Error: 53)

I am running win2k. I also enabled named pipes and tcpip and cannot get connected...Anyone have any idea on this? the hosting company seems stumped.
I have no firewall running, no antivirus and my router is set to defaults no security.
Steve Jones
Steve Jones
SSC Guru
SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)

Group: Administrators
Points: 150602 Visits: 19455
First, did you add named pipes to the server? I'm not sure named pipes works through routers. I think it's a networking issue. You can use sp_configure or EM to set the "allow remote connections" to on.

Be sure that the hosting company isn't filtering out 1433, which is the default method to connect.

Are you connecting from the web server or from your machine?


Lastly, please post in the appropriate forum. I moved this to the 2005 forum.

Follow me on Twitter: @way0utwest
Forum Etiquette: How to post data/code on a forum to get the best help
My Blog: www.voiceofthedba.com
chrismiller
chrismiller
SSC-Enthusiastic
SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)

Group: General Forum Members
Points: 119 Visits: 141
Sorry about posting in the wrong area..
I spoke with my isp as well as the hosting company, neither is filtering out 1433.
i'm trying to connect from my pc. I have a website that allows me to use sql server db's and they can connect to it, but i keep getting the same error.
From my pc in the ssm express i have enabled remote connections..as for the sp_configure i really have no idea on how to use it.
I have connected to sql db's on intranets at a company that i used to work for but this kind of remote connection is new to me.

I have 2 pcs, one in the basement which has a router connected to the main modem and my pc ( that is upstairs ) that has a wireless card in it. my pc upstairs is the one i am trying to connect to.
Maverick100877
Maverick100877
SSCrazy
SSCrazy (2.3K reputation)SSCrazy (2.3K reputation)SSCrazy (2.3K reputation)SSCrazy (2.3K reputation)SSCrazy (2.3K reputation)SSCrazy (2.3K reputation)SSCrazy (2.3K reputation)SSCrazy (2.3K reputation)

Group: General Forum Members
Points: 2298 Visits: 659
Please check if the SQL Browser service is running or not?
Hemantgiri S. Goswami
Hemantgiri S. Goswami
SSC-Enthusiastic
SSC-Enthusiastic (146 reputation)SSC-Enthusiastic (146 reputation)SSC-Enthusiastic (146 reputation)SSC-Enthusiastic (146 reputation)SSC-Enthusiastic (146 reputation)SSC-Enthusiastic (146 reputation)SSC-Enthusiastic (146 reputation)SSC-Enthusiastic (146 reputation)

Group: General Forum Members
Points: 146 Visits: 228
Hi,
you need to enable remote connection at your Host server, follow and check the steps listed here http://support.microsoft.com/kb/914277

Hemantgiri S. Goswami | SQL Server Specialist & Consultant
SQL Server Citation | Follow me on Twitter
chrismiller
chrismiller
SSC-Enthusiastic
SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)

Group: General Forum Members
Points: 119 Visits: 141
Hi Old, yes the sql server browser is running.
Hemant, I have spoke with hosting company they are allowing remote connections. They changed me over to a new server but that still doesn't work.
chrismiller
chrismiller
SSC-Enthusiastic
SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)

Group: General Forum Members
Points: 119 Visits: 141
Hi Old, yes the sql server browser is running.
Hemant, I have spoke with hosting company they are allowing remote connections. They changed me over to a new server but that still doesn't work.
Ed Salyer
Ed Salyer
Forum Newbie
Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)

Group: General Forum Members
Points: 5 Visits: 107
I had the same problem last week. I created a SQL 2005 database server on the same server I was running SQL 2000 on. When I tried to connect from an XP machine, I got the same error you describe. What I found to be my problem was not having File and Printer Sharing as an allowed Firewall exception along with the exceptions for sqlbrowser.exe and sqlserver.exe which I had created.
chrismiller
chrismiller
SSC-Enthusiastic
SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)SSC-Enthusiastic (119 reputation)

Group: General Forum Members
Points: 119 Visits: 141
Hi Ed,
I don't have any firewall on my pc and file printer sharing is enabled. I also had a friend of mine try connecting the the host server and he gets the same error I do. I have sent a tracert to the hosting company and it times out just before their server.

They have this asp.net enterprise manager web app that i can use to do my database stuff but its very limited, and annoying to use.
Steve Jones
Steve Jones
SSC Guru
SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)SSC Guru (150K reputation)

Group: Administrators
Points: 150602 Visits: 19455
Sorry for the delay, Chris.

Let me try and explain how this works and then maybe you'll see a hole in what's happening.

When you install SQL Server 2005, it runs on TCP/IP by default, port 1433, and allows you to connect with any Windows PC, using the standard ODBC dialogs. You connect using either the IP, the Windows name (+ /instancename if you use instances), or if you are on the console, then using "(local)".

SQL Server Express only allows local connections, meaning from the console of that server, by default, but the other editions should allow remote connections. However you need to check this using another machine. If the hosting company says they can connect from their workstations, not being the console, then that's not the issue.

When you connect with SSMS, SSMS is on your workstation and makes a socket connection to SQL Server, even if SQL Server is on your local machine. So you can't necessarily use SSMS to check settings on the server.

From what you're describing, it sounds like either they're a networking issue, or you are using Named Pipes by default to connect to a remote machine. Try opening the SSMS, typing in the address of the server, then hitting options. Manually choose TCP/IP to connect. See what happens.

alternatively, I'll try from here if you want to email me directly (sjones @ sqlservercentral.com). Set up a new user, or get the hosting company to change the password for a one time connect that you can change or remove after a test.

Steve

Follow me on Twitter: @way0utwest
Forum Etiquette: How to post data/code on a forum to get the best help
My Blog: www.voiceofthedba.com
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search