SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


C# ADOMD Connection error - Element return was not found


C# ADOMD Connection error - Element return was not found

Author
Message
Ludo-ZX7R
Ludo-ZX7R
Say Hey Kid
Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)

Group: General Forum Members
Points: 666 Visits: 789
Hi guys

I am trying to put together a Dashboard using VS2012 in c#. I want to connect to my Cube in order to retrieve the Data to be displayed in Graphs.

I have the following connection:
AdomdConnection myconnect = new AdomdConnection(@"provider=msolap.5;initial catalog=Cube;datasource=xx.xx.xx.xx;UID=MyUser;PWD=MyPassword;Timeout=10000;connect timeout=1000");

When I replace xx.xx.xx.xx (in AWS) by "localhost" I can connect and run MDX Queries otherwise I get the Element error.

In some forums, some people advise to increase the timeout delay but it doesn't seem to make any difference. The error message comes back straight after calling Open() whatever value I use.

Any ideas?

Cheers
Andrew G
Andrew G
SSCarpal Tunnel
SSCarpal Tunnel (4.1K reputation)SSCarpal Tunnel (4.1K reputation)SSCarpal Tunnel (4.1K reputation)SSCarpal Tunnel (4.1K reputation)SSCarpal Tunnel (4.1K reputation)SSCarpal Tunnel (4.1K reputation)SSCarpal Tunnel (4.1K reputation)SSCarpal Tunnel (4.1K reputation)

Group: General Forum Members
Points: 4063 Visits: 2281
Add the port number to the IP address. To find the correct port number: http://support.microsoft.com/kb/2466860
Ludo-ZX7R
Ludo-ZX7R
Say Hey Kid
Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)Say Hey Kid (666 reputation)

Group: General Forum Members
Points: 666 Visits: 789
Hi

Thanks for the info but I have already tried with xx.xx.xx.xx:2383 an go the same result.

Cheers
Waldo Walden
Waldo Walden
Forum Newbie
Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)

Group: General Forum Members
Points: 9 Visits: 3
If you are using the ADOMD.NET DLL installed under C:\Program Files\Microsoft.NET\ADOMD.NET\120, try referencing the one under the "100" folder instead.

I was getting the same error and this worked for me.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search