SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


When a SQL file will not open in SSMS


When a SQL file will not open in SSMS

Author
Message
lyco_us
lyco_us
Forum Newbie
Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)Forum Newbie (4 reputation)

Group: General Forum Members
Points: 4 Visits: 133
Comments posted to this topic are about the item When a SQL file will not open in SSMS
Craigmeister
Craigmeister
SSC Veteran
SSC Veteran (230 reputation)SSC Veteran (230 reputation)SSC Veteran (230 reputation)SSC Veteran (230 reputation)SSC Veteran (230 reputation)SSC Veteran (230 reputation)SSC Veteran (230 reputation)SSC Veteran (230 reputation)

Group: General Forum Members
Points: 230 Visits: 557
Nice job sniffing that one out. That little tip will make me look like a super SQL expert with the boss as I am sure that if anyone here has that issue it will be him.

Thanks.
paul.knibbs
paul.knibbs
SSCarpal Tunnel
SSCarpal Tunnel (4.2K reputation)SSCarpal Tunnel (4.2K reputation)SSCarpal Tunnel (4.2K reputation)SSCarpal Tunnel (4.2K reputation)SSCarpal Tunnel (4.2K reputation)SSCarpal Tunnel (4.2K reputation)SSCarpal Tunnel (4.2K reputation)SSCarpal Tunnel (4.2K reputation)

Group: General Forum Members
Points: 4188 Visits: 6240
You actually get a similar problem if you have a SQL file that's Unicode but without the proper Unicode byte-ordering mark at the beginning--that'll open in Notepad when you double-click it, rather than SSMS! Had that issue the other week.
jcunningham
jcunningham
SSC Veteran
SSC Veteran (244 reputation)SSC Veteran (244 reputation)SSC Veteran (244 reputation)SSC Veteran (244 reputation)SSC Veteran (244 reputation)SSC Veteran (244 reputation)SSC Veteran (244 reputation)SSC Veteran (244 reputation)

Group: General Forum Members
Points: 244 Visits: 174
This worked for me on Windows 7, but it did not work on my Server 2008 R2 box. Anyone else having this issue there?
Libby
Libby
SSC Veteran
SSC Veteran (221 reputation)SSC Veteran (221 reputation)SSC Veteran (221 reputation)SSC Veteran (221 reputation)SSC Veteran (221 reputation)SSC Veteran (221 reputation)SSC Veteran (221 reputation)SSC Veteran (221 reputation)

Group: General Forum Members
Points: 221 Visits: 248
I have not had the problem - but do appreciate you taking the time to document it. Thanks!
margo@on2morning.com
margo@on2morning.com
SSC-Enthusiastic
SSC-Enthusiastic (172 reputation)SSC-Enthusiastic (172 reputation)SSC-Enthusiastic (172 reputation)SSC-Enthusiastic (172 reputation)SSC-Enthusiastic (172 reputation)SSC-Enthusiastic (172 reputation)SSC-Enthusiastic (172 reputation)SSC-Enthusiastic (172 reputation)

Group: General Forum Members
Points: 172 Visits: 155
I have this exact same thing (not sure what's caused it). I tried your tip, but it didn't work for me. Maybe uninstalling/reinstalling helped you out after all? I'm not sure I want to go through that much effort, but it is annoying...
TedNESG
TedNESG
Forum Newbie
Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)

Group: General Forum Members
Points: 5 Visits: 37
Good Grief ! A simple thing can cause so much aggravation. Thanks for sharing...just updated my SSMS

Ted
chrisfradenburg
chrisfradenburg
SSCrazy
SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)

Group: General Forum Members
Points: 2956 Visits: 2076
Have you tried looking for the registry key he mentioned? If that's there then maybe you have the problem that the other people were addressing instead of the one Lynn did.
thisisfutile
thisisfutile
Say Hey Kid
Say Hey Kid (705 reputation)Say Hey Kid (705 reputation)Say Hey Kid (705 reputation)Say Hey Kid (705 reputation)Say Hey Kid (705 reputation)Say Hey Kid (705 reputation)Say Hey Kid (705 reputation)Say Hey Kid (705 reputation)

Group: General Forum Members
Points: 705 Visits: 1005
On my workstation, the Options > Source Control only has "Plug-in Selection" under it in the tree menu so file association through SSMS isn't an option on my install.

I know for a fact this all started when I installed SQL 2008 Express over top of my SSMS 2005 on my workstation. My setup is a 2005 server on a different box and my workstation has always had 2005 SSMS on it for administring the server. Some time ago I installed 2008 Express on this workstation and that's the day my trouble began. So, that leads me to believe that my 2008 SSMS install doesn't offer the "file association" option.

Thanks for posting this because I too have scoured forums only to find the registry tweak you mentioned above. I've also tried just using Windows File Association settings with some fancy suggestions on those same forums but those not only wouldn't open the files, they also generated a new warning pop-up window too.

UPDATE: I just realized I was looking in the wrong area but made the mistake of making a second post to announce it...sheesh, one mistake on top of another...I'll be SO GLAD when we get our office moved at the end of this week (slightly stressed-out here) :-P
Mary Kay Malensek
Mary Kay Malensek
SSC Rookie
SSC Rookie (26 reputation)SSC Rookie (26 reputation)SSC Rookie (26 reputation)SSC Rookie (26 reputation)SSC Rookie (26 reputation)SSC Rookie (26 reputation)SSC Rookie (26 reputation)SSC Rookie (26 reputation)

Group: General Forum Members
Points: 26 Visits: 106
I have the same exact scenario, but unfortunately this didn't fix it for me. I was really hopeful, so thanks for posting this. And I already checked my registry key and tried uninstalling and re-installing. It's just annoying issue.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search