SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Confused on memory


Confused on memory

Author
Message
saby
saby
SSChasing Mays
SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)

Group: General Forum Members
Points: 659 Visits: 277
hi m having a server which has 20 gb ram i hav give the 15 gb(max memory) to sqlserver but wen i check in wth permon total memory show on 3.5 GB...
saby
saby
SSChasing Mays
SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)SSChasing Mays (659 reputation)

Group: General Forum Members
Points: 659 Visits: 277
waiting for the suggestions..........
FNS
FNS
Right there with Babe
Right there with Babe (759 reputation)Right there with Babe (759 reputation)Right there with Babe (759 reputation)Right there with Babe (759 reputation)Right there with Babe (759 reputation)Right there with Babe (759 reputation)Right there with Babe (759 reputation)Right there with Babe (759 reputation)

Group: General Forum Members
Points: 759 Visits: 584
What version of SQL / Windoze are you running, 32-bit or 64-bit?
What are your memory settings for AWE, boot.ini and so on?
forsqlserver
forsqlserver
SSCrazy Eights
SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)

Group: General Forum Members
Points: 8134 Visits: 2072
Dear

what is AWE?

Plz tell ....

Thanx

Thanks
Kishore.P
Kishore.P
SSCarpal Tunnel
SSCarpal Tunnel (4K reputation)SSCarpal Tunnel (4K reputation)SSCarpal Tunnel (4K reputation)SSCarpal Tunnel (4K reputation)SSCarpal Tunnel (4K reputation)SSCarpal Tunnel (4K reputation)SSCarpal Tunnel (4K reputation)SSCarpal Tunnel (4K reputation)

Group: General Forum Members
Points: 4027 Visits: 619
guptaajay1985 (12/2/2008)
Dear

what is AWE?

Plz tell ....

Thanx


see the link:
http://support.microsoft.com/default.aspx/kb/274750
http://msdn.microsoft.com/en-us/library/ms175581.aspx



forsqlserver
forsqlserver
SSCrazy Eights
SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)SSCrazy Eights (8.1K reputation)

Group: General Forum Members
Points: 8134 Visits: 2072
Thanx Dear..

Thanks
TheSQLGuru
TheSQLGuru
SSC Guru
SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)

Group: General Forum Members
Points: 58123 Visits: 8824
SQL Server only takes memory as it is needed. Perhaps you only have (or access) a few GBs of data?

Best,
Kevin G. Boles
SQL Server Consultant
SQL MVP 2007-2012
TheSQLGuru on googles mail service
GabyYYZ
GabyYYZ
SSCrazy
SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)

Group: General Forum Members
Points: 2953 Visits: 2336
Read the previously posted articles, but a quick summary:

1. If you have 64-bit windows, skip this step and go to step 2. If you have 32-bit Windows, right click on the server in object explorer and click Properties. Select the Memory page and make sure AWE is checked (as well as adjusting your memory to desired settings). Save and close.

2. Go to Administrative Tools -> Local Security Policy and inside the window, select Local Policies -> User Rights Assignment.s You will see a whole list of policies on the right hand side. The one you need is Lock pages in Memory. Double click on it and add the service account(s) you are running your SQL Server instance(s) as.

NOTE: This will involve restarting your SQL Service to become effective, so if this is a production environment, beware of that.

This is the quick and dirty version of setting up AWE and Lock Pages in Memory, but read the articles to get a thorough introduction before proceeding.

Gaby
________________________________________________________________
"In theory, theory and practice are the same. In practice, they are not."
- Albert Einstein

GSquared
GSquared
SSC Guru
SSC Guru (105K reputation)SSC Guru (105K reputation)SSC Guru (105K reputation)SSC Guru (105K reputation)SSC Guru (105K reputation)SSC Guru (105K reputation)SSC Guru (105K reputation)SSC Guru (105K reputation)

Group: General Forum Members
Points: 105525 Visits: 9730
And, of course, if you're using a "Standard" version of Windows Server, you can't address that much RAM anyway.

- Gus "GSquared", RSVP, OODA, MAP, NMVP, FAQ, SAT, SQL, DNA, RNA, UOI, IOU, AM, PM, AD, BC, BCE, USA, UN, CF, ROFL, LOL, ETC
Property of The Thread

"Nobody knows the age of the human race, but everyone agrees it's old enough to know better." - Anon
TheSQLGuru
TheSQLGuru
SSC Guru
SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)SSC Guru (58K reputation)

Group: General Forum Members
Points: 58123 Visits: 8824
Gaby Abed (12/3/2008)
Read the previously posted articles, but a quick summary:

1. If you have 64-bit windows, skip this step and go to step 2. If you have 32-bit Windows, right click on the server in object explorer and click Properties. Select the Memory page and make sure AWE is checked (as well as adjusting your memory to desired settings). Save and close.

2. Go to Administrative Tools -> Local Security Policy and inside the window, select Local Policies -> User Rights Assignment.s You will see a whole list of policies on the right hand side. The one you need is Lock pages in Memory. Double click on it and add the service account(s) you are running your SQL Server instance(s) as.

NOTE: This will involve restarting your SQL Service to become effective, so if this is a production environment, beware of that.

This is the quick and dirty version of setting up AWE and Lock Pages in Memory, but read the articles to get a thorough introduction before proceeding.


1) if 32 bit you would also need /PAE in the boot.ini file, right?

2) IIRC Lock pages in memory is only useful for SQL Server Enterprise Edition.

Best,
Kevin G. Boles
SQL Server Consultant
SQL MVP 2007-2012
TheSQLGuru on googles mail service
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum







































































































































































SQLServerCentral


Search