SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Caution about Restoring via SSMS v17


Caution about Restoring via SSMS v17

Author
Message
NJ-DBA
NJ-DBA
SSChampion
SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)

Group: General Forum Members
Points: 12600 Visits: 1687
Comments posted to this topic are about the item Caution about Restoring via SSMS v17
About SQL
About SQL
Grasshopper
Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)

Group: General Forum Members
Points: 18 Visits: 19
I'm using 17.8.1 version of SSMS but default for me is "RESTORE WITH RECOVERY" so I don't undestand your article.
Where i mistake ?
dperdices
dperdices
Grasshopper
Grasshopper (20 reputation)Grasshopper (20 reputation)Grasshopper (20 reputation)Grasshopper (20 reputation)Grasshopper (20 reputation)Grasshopper (20 reputation)Grasshopper (20 reputation)Grasshopper (20 reputation)

Group: General Forum Members
Points: 20 Visits: 15
I think he refers to the second check marked in yellow.

This two options as far I remember have been checked for default if the database is in full or bulk logged recovery model.
About SQL
About SQL
Grasshopper
Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)

Group: General Forum Members
Points: 18 Visits: 19
Yes, in my case SQL is with "RECOVERY SIMPLE" so all is ok but i think was better if you specify this condition in your article.
Thanks
sqlcl
sqlcl
SSC Journeyman
SSC Journeyman (91 reputation)SSC Journeyman (91 reputation)SSC Journeyman (91 reputation)SSC Journeyman (91 reputation)SSC Journeyman (91 reputation)SSC Journeyman (91 reputation)SSC Journeyman (91 reputation)SSC Journeyman (91 reputation)

Group: General Forum Members
Points: 91 Visits: 221
In SQL Server 2016 SP1 too.
webrunner
webrunner
One Orange Chip
One Orange Chip (26K reputation)One Orange Chip (26K reputation)One Orange Chip (26K reputation)One Orange Chip (26K reputation)One Orange Chip (26K reputation)One Orange Chip (26K reputation)One Orange Chip (26K reputation)One Orange Chip (26K reputation)

Group: General Forum Members
Points: 26998 Visits: 4429
Thanks for this heads-up. I've seen the tail-log option appear for me as described in the article. Luckily I did check the different dialog boxes and noticed it, so I was able to uncheck it. In my case it was only for a non-production database, but seeing the tail-log option checked by default certainly caught my eye.

Thanks again,
webrunner

-------------------
A SQL query walks into a bar and sees two tables. He walks up to them and says Can I join you?
Ref.: http://tkyte.blogspot.com/2009/02/sql-joke.html
sqlfriends
sqlfriends
SSC-Forever
SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)

Group: General Forum Members
Points: 46608 Visits: 4732
Thanks for the article, that is a good reminder.

Not sure why microsoft make the checkbox checked as default? why the source database has to be in nonrecovery mode?

Thanks
Lynn Pettis
Lynn Pettis
SSC Guru
SSC Guru (396K reputation)SSC Guru (396K reputation)SSC Guru (396K reputation)SSC Guru (396K reputation)SSC Guru (396K reputation)SSC Guru (396K reputation)SSC Guru (396K reputation)SSC Guru (396K reputation)

Group: General Forum Members
Points: 396787 Visits: 43205
sqlfriends - Tuesday, November 6, 2018 9:26 AM
Thanks for the article, that is a good reminder.

Not sure why microsoft make the checkbox checked as default? why the source database has to be in nonrecovery mode?

Thanks

If you are taking a tail log backup of the database you don't want additional transactions being applied. Defeats the reason for a tail log backup.


Cool
Lynn Pettis

For better assistance in answering your questions, click here
For tips to get better help with Performance Problems, click here
For Running Totals and its variations, click here or when working with partitioned tables
For more about Tally Tables, click here
For more about Cross Tabs and Pivots, click here and here
Managing Transaction Logs

SQL Musings from the Desert Fountain Valley SQL (My Mirror Blog)
NJ-DBA
NJ-DBA
SSChampion
SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)SSChampion (12K reputation)

Group: General Forum Members
Points: 12600 Visits: 1687
Lynn Pettis - Tuesday, November 6, 2018 9:42 AM
sqlfriends - Tuesday, November 6, 2018 9:26 AM
Thanks for the article, that is a good reminder.

Not sure why microsoft make the checkbox checked as default? why the source database has to be in nonrecovery mode?

Thanks

If you are taking a tail log backup of the database you don't want additional transactions being applied. Defeats the reason for a tail log backup.

Yes, but why make it the default to take a tail log backup... just because I'm restoring a copy of another database, doesnt mean I want that one taken offline. In my case, I'm usually making a copy and keeping both online.

sqlfriends
sqlfriends
SSC-Forever
SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)SSC-Forever (46K reputation)

Group: General Forum Members
Points: 46608 Visits: 4732
I found if you restore a copy to overwrite the same database, it makes sense to have that checked as default.

As NJ_DBA, in my case I usually restore the database to a different database and keep both online.Then check that as default, makes no sense.

Thanks,
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search