SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


S‌QL Server using 97% of RAM.


S‌QL Server using 97% of RAM.

Author
Message
coolchaitu
coolchaitu
Hall of Fame
Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)

Group: General Forum Members
Points: 3617 Visits: 1341
Good Morning Experts,
SQL Server is using 97% of RAM. Could you please advise what needs to be done.
John Mitchell-245523
John Mitchell-245523
SSC Guru
SSC Guru (67K reputation)SSC Guru (67K reputation)SSC Guru (67K reputation)SSC Guru (67K reputation)SSC Guru (67K reputation)SSC Guru (67K reputation)SSC Guru (67K reputation)SSC Guru (67K reputation)

Group: General Forum Members
Points: 67662 Visits: 17500
(1) Make sure you set max server memory such that there is sufficient memory left for the operating system and any other applications or SQL Server components on the server
Then...
(2) Be happy that SQL Server is running as it should.

John
Grant Fritchey
Grant Fritchey
SSC Guru
SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)

Group: General Forum Members
Points: 183340 Visits: 33294
By design, SQL Server will take every bit of memory that you offer it. It's supposed to. It will grow into the memory allocation limit that you set and then it will sit there, all the time. It's one reason why monitoring percent of memory used is kind of a waste of time. As for as what to set it to, here's some very good guidance from a source I trust.

----------------------------------------------------
The credit belongs to the man who is actually in the arena, whose face is marred by dust and sweat and blood...
Theodore Roosevelt

The Scary DBA
Author of: SQL Server Query Performance Tuning and SQL Server Execution Plans
Product Evangelist for Red Gate Software
Steve Jones
Steve Jones
SSC Guru
SSC Guru (277K reputation)SSC Guru (277K reputation)SSC Guru (277K reputation)SSC Guru (277K reputation)SSC Guru (277K reputation)SSC Guru (277K reputation)SSC Guru (277K reputation)SSC Guru (277K reputation)

Group: Administrators
Points: 277787 Visits: 19896
You can also look at Target Server Memory in Performance monitor to get an idea of what SQL Server thinks it needs.

Follow me on Twitter: @way0utwest
Forum Etiquette: How to post data/code on a forum to get the best help
My Blog: www.voiceofthedba.com
coolchaitu
coolchaitu
Hall of Fame
Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)Hall of Fame (3.6K reputation)

Group: General Forum Members
Points: 3617 Visits: 1341
Steve Jones - SSC Editor - Monday, November 13, 2017 11:56 AM
You can also look at Target Server Memory in Performance monitor to get an idea of what SQL Server thinks it needs.

SQL Server memory usage reached to 99%. Please let me know what should i do. Shall I decrease the max server memory value?

vimazi
vimazi
Forum Newbie
Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)

Group: General Forum Members
Points: 7 Visits: 11
Hi coolchaitu,

You should limit the memory SQL Server uses. In the SQL Server Management Studio, after you connect to the db server:
1. Right click on the name and choose Properties
2. In the Server Properties window, choose Memory
3. In this window you have Server memory options. Edit the Maximum server memory(in MB) to the value you think it would be appropriate in your case (i've set it to max 80% of the total RAM available, but you could adapt).
You have to restart the server for the setting to become effective.

Let me know if it helps.
NorthernSoul
NorthernSoul
SSCrazy
SSCrazy (2.7K reputation)SSCrazy (2.7K reputation)SSCrazy (2.7K reputation)SSCrazy (2.7K reputation)SSCrazy (2.7K reputation)SSCrazy (2.7K reputation)SSCrazy (2.7K reputation)SSCrazy (2.7K reputation)

Group: General Forum Members
Points: 2656 Visits: 6057
vimazi - Tuesday, November 14, 2017 4:03 AM
Hi coolchaitu,

You should limit the memory SQL Server uses. In the SQL Server Management Studio, after you connect to the db server:
1. Right click on the name and choose Properties
2. In the Server Properties window, choose Memory
3. In this window you have Server memory options. Edit the Maximum server memory(in MB) to the value you think it would be appropriate in your case (i've set it to max 80% of the total RAM available, but you could adapt).
You have to restart the server for the setting to become effective.

Let me know if it helps.

Just to point out you don't have to re-start for the changes to take effect.

Thanks

Jeff Moden
Jeff Moden
SSC Guru
SSC Guru (425K reputation)SSC Guru (425K reputation)SSC Guru (425K reputation)SSC Guru (425K reputation)SSC Guru (425K reputation)SSC Guru (425K reputation)SSC Guru (425K reputation)SSC Guru (425K reputation)

Group: General Forum Members
Points: 425515 Visits: 43415
Also to point out and speaking from a bit of experience where I made a Phat Phinger mistake... BE VERY VERY CAREFUL WHEN MAKING THE SETTING CHANGE!!!! If you screw up and tell the server to only use, say, 100MB max memory by mistake, you may not be able to fix it and because you won't be able to start SQL Server to fix it.

--Jeff Moden

RBAR is pronounced ree-bar and is a Modenism for Row-By-Agonizing-Row.
First step towards the paradigm shift of writing Set Based code:
Stop thinking about what you want to do to a row... think, instead, of what you want to do to a column.
If you think its expensive to hire a professional to do the job, wait until you hire an amateur. -- Red Adair

Helpful Links:
How to post code problems
How to post performance problems
Forum FAQs
Grant Fritchey
Grant Fritchey
SSC Guru
SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)SSC Guru (183K reputation)

Group: General Forum Members
Points: 183340 Visits: 33294
Jeff Moden - Tuesday, November 14, 2017 8:56 AM
Also to point out and speaking from a bit of experience where I made a Phat Phinger mistake... BE VERY VERY CAREFUL WHEN MAKING THE SETTING CHANGE!!!! If you screw up and tell the server to only use, say, 100MB max memory by mistake, you may not be able to fix it and because you won't be able to start SQL Server to fix it.


yeah, I did this too. There is a way to force the memory setting on startup. It's a traceflag somewhere. If you do make this happen (as I did), you can get out of it... after a lot of panicked searching on the web.

----------------------------------------------------
The credit belongs to the man who is actually in the arena, whose face is marred by dust and sweat and blood...
Theodore Roosevelt

The Scary DBA
Author of: SQL Server Query Performance Tuning and SQL Server Execution Plans
Product Evangelist for Red Gate Software
GilaMonster
GilaMonster
SSC Guru
SSC Guru (461K reputation)SSC Guru (461K reputation)SSC Guru (461K reputation)SSC Guru (461K reputation)SSC Guru (461K reputation)SSC Guru (461K reputation)SSC Guru (461K reputation)SSC Guru (461K reputation)

Group: General Forum Members
Points: 461918 Visits: 47313
Grant Fritchey - Tuesday, November 14, 2017 1:51 PM
Jeff Moden - Tuesday, November 14, 2017 8:56 AM
Also to point out and speaking from a bit of experience where I made a Phat Phinger mistake... BE VERY VERY CAREFUL WHEN MAKING THE SETTING CHANGE!!!! If you screw up and tell the server to only use, say, 100MB max memory by mistake, you may not be able to fix it and because you won't be able to start SQL Server to fix it.


yeah, I did this too. There is a way to force the memory setting on startup. It's a traceflag somewhere. If you do make this happen (as I did), you can get out of it... after a lot of panicked searching on the web.

-f startup switch, to start in minimal configuration


Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass


Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum







































































































































































SQLServerCentral


Search