Viewing 15 posts - 17,521 through 17,535 (of 49,552 total)
Duplicate post. No replies to this thread please. Direct replies to:http://www.sqlservercentral.com/Forums/Topic1332736-3077-1.aspx
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 20, 2012 at 1:23 am
Get Grant's book
or
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 20, 2012 at 1:18 am
painulyanoop (7/20/2012)
ALTER DATABASE [testdb] SET RECOVERY SIMPLE WITH NO_WAITDBCC SHRINKFILE('SMS2.2_log', 1)
ALTER DATABASE [TestDb] SET RECOVERY FULL WITH NO_WAIT
Dbcc ShrinkDatabase(testdb, TruncateOnly)
You can start by removing this.
Breaks database recovery path, results...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 20, 2012 at 1:16 am
ab289 (7/19/2012)
What do you mean by "new certs have to be renewed"?
Exactly that, they're not permanently valid (like the older exams were),they have to be renewed
How do you renew...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 20, 2012 at 1:10 am
No, the initial size has no effect, that's literally just the size the log started.
Log reuse wait desc when the user gets that error?
How big is the log file?
Is autogrow...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 20, 2012 at 1:08 am
You can, but watch the licensing terms on Developer edition. It cannot be used for production in any way.
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 6:30 pm
Yes, that is how you create a primary key.
Check what error it's failing with if it doesn't set the PK (my guess, the column is nullable)
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 5:33 pm
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 5:31 pm
Please read through this: http://www.sqlservercentral.com/articles/Transaction+Log/72488/
Run a checkpoint first, the value of log_reuse in sys.databases doesn't always immediately update.
If nothing is holding the log active (log reuse of NOTHING) and shrink...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 5:27 pm
Gianluca Sartori (7/19/2012)
How am I supposed to fail-over the instances if I can't reach the cluster admin snap-in?
What permissions does the SQL Server service account have, and is xp_cmdshell enabled...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 5:24 pm
cmoy (7/19/2012)
Oh well, looks like another 2 weeks at this rate....
Not necessarily, depends how and where the free space is within the data file. The further towards the beginning of...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 3:00 pm
Why a tbl prefix anyway? It's obvious it's a table from how it's used.
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 2:56 pm
SQL ORACLE (7/19/2012)
Robert Davis (7/19/2012)
SQL ORACLE (7/19/2012)
Make a full backup for this database and then shrink the database.What difference will that make?
We need to truncate the log to release the...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 2:52 pm
Error messages please? All relevant ones from the SQL error log. Plus a more detailed description of exactly what's wrong. I'm not sure if you have a database that won't...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 1:56 pm
GSquared (7/19/2012)
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
July 19, 2012 at 12:30 pm
Viewing 15 posts - 17,521 through 17,535 (of 49,552 total)