Viewing 15 posts - 15,376 through 15,390 (of 49,552 total)
By rebuilding the tran log you may have lost transactional consistency and possibly even structural consistency in the database, depending what was running before you deleted it. Rebuilding the log...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 11:52 am
That one's running fine.
If you have another SQL instance that isn't running/won't start, find the error log from that instance (check the startup parameters in SQL config manager...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 9:04 am
CheckDB when run with the options specified in the first portion of that article just lists the errors.
Other important things to know, when did the errors start, do you have...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 8:49 am
Find the SQL error log. What errors does it list at the end?
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 8:37 am
daniel.kling (12/4/2012)
Yeah, you're reading it right, I deleted it. I thought it was just a log file :blush:
Errrr... just as in the log of transactions that is the portion of...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 8:32 am
zeycus (12/4/2012)
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 8:31 am
arunyadav007 (12/3/2012)
If not, you can try thisUSE MASTER
GO
DBCC FREESESSIONCACHE WITH NO_INFOMSGS
GO
DBCC FREESYSTEMCACHE 'ALL'
GO
USE (YOURDBNAME)
GO
DBCC SHRINKFILE (N'LOGFILENAME', 0, TRUNCATEONLY)
GO
DBCC SHRINKFILE (N'LOGFILENAME' , 1024)
GO
Well, I suppose that you can try that, but...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 7:10 am
What is the exact state of the database (the state_desc column in Sys.databases ) and what are all of the messages relating to that DB in the error log?
Edit: Am...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 7:00 am
Try doing it in a single statement
Insert into Tasks ...
SELECT max(Id) + 1, ... From Tasks
That should work.
Otherwise you will need to force a different lock on the select. It's...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 6:58 am
bjopette (12/4/2012)
The following transaction logs will be based on the backup the developer made
Log backups are not based on a specific full backup (except when it's the first full backup...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 4, 2012 at 3:53 am
What exactly do you mean by 'truncate log'?
If you mean shrink, it's a waste of time, the log will just grow again. If you mean log backup, perfectly safe.
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 3, 2012 at 3:49 pm
*sigh* So my book shop loyalty program gives me a free movie ticket for my birthday, valid for a week from that day. Yay, so I can go see The...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 3, 2012 at 3:37 pm
Yup. If you split the range when there's data that will qualify for the new range, SQL has to move that data to a new partition, which kinda defeats the...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 3, 2012 at 3:33 pm
If you have a clean backup (one without any corruption) and an unbroken chain of log backups up to present, you can do a page restore. Or you can restore...
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 3, 2012 at 3:33 pm
Don't try to read the XML plan raw. It's possible if you like pain.
SAve the xml as a .sqlplan file and open that file in management studio.
Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability
December 3, 2012 at 12:54 pm
Viewing 15 posts - 15,376 through 15,390 (of 49,552 total)