Forum Replies Created

Viewing 15 posts - 15,376 through 15,390 (of 49,552 total)

  • RE: Database not available after restarting windows services

    By rebuilding the tran log you may have lost transactional consistency and possibly even structural consistency in the database, depending what was running before you deleted it. Rebuilding the log...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: HELP! Resized disk SQL is installed on and now SQL won't start

    That one's running fine.

    If you have another SQL instance that isn't running/won't start, find the error log from that instance (check the startup parameters in SQL config manager...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Error, not sure where to start: Attept to fetch logical page... failed. incorrect checkum

    CheckDB when run with the options specified in the first portion of that article just lists the errors.

    Other important things to know, when did the errors start, do you have...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: HELP! Resized disk SQL is installed on and now SQL won't start

    Find the SQL error log. What errors does it list at the end?

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Database not available after restarting windows services

    daniel.kling (12/4/2012)


    Yeah, you're reading it right, I deleted it. I thought it was just a log file :blush:

    Errrr... just as in the log of transactions that is the portion of...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Force read lock in a table, to avoid problems between parallel processes.

    zeycus (12/4/2012)


    Maybe this question is dumb. If I do this, having both queries are encapsulated in a transaction, and two different processes launch this transaction, the problem cannot happen? Is...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: how to shrink logfile ?

    arunyadav007 (12/3/2012)


    If not, you can try this

    USE MASTER

    GO

    DBCC FREESESSIONCACHE WITH NO_INFOMSGS

    GO

    DBCC FREESYSTEMCACHE 'ALL'

    GO

    USE (YOURDBNAME)

    GO

    DBCC SHRINKFILE (N'LOGFILENAME', 0, TRUNCATEONLY)

    GO

    DBCC SHRINKFILE (N'LOGFILENAME' , 1024)

    GO

    Well, I suppose that you can try that, but...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Database not available after restarting windows services

    What is the exact state of the database (the state_desc column in Sys.databases ) and what are all of the messages relating to that DB in the error log?

    Edit: Am...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Force read lock in a table, to avoid problems between parallel processes.

    Try doing it in a single statement

    Insert into Tasks ...

    SELECT max(Id) + 1, ... From Tasks

    That should work.

    Otherwise you will need to force a different lock on the select. It's...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Create a policy to avoid backups withou copy_only option

    bjopette (12/4/2012)


    The following transaction logs will be based on the backup the developer made

    Log backups are not based on a specific full backup (except when it's the first full backup...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Truncate Log File

    What exactly do you mean by 'truncate log'?

    If you mean shrink, it's a waste of time, the log will just grow again. If you mean log backup, perfectly safe.

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: Are the posted questions getting worse?

    *sigh* So my book shop loyalty program gives me a free movie ticket for my birthday, valid for a week from that day. Yay, so I can go see The...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: SPLIT RANGE TOOK 10 HRS to Complete

    Yup. If you split the range when there's data that will qualify for the new range, SQL has to move that data to a new partition, which kinda defeats the...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: checkdb error on index ID 0

    If you have a clean backup (one without any corruption) and an unbroken chain of log backups up to present, you can do a page restore. Or you can restore...

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass
  • RE: how to extract value from showplan_xml?

    Don't try to read the XML plan raw. It's possible if you like pain.

    SAve the xml as a .sqlplan file and open that file in management studio.

    Gail Shaw
    Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
    SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

    We walk in the dark places no others will enter
    We stand on the bridge and no one may pass

Viewing 15 posts - 15,376 through 15,390 (of 49,552 total)