SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Some problem in SSIS 2008 when Excel is used


Some problem in SSIS 2008 when Excel is used

Author
Message
only4mithunc
only4mithunc
SSCommitted
SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)

Group: General Forum Members
Points: 1690 Visits: 2803
Hi friends,

Is there any known issue with EXcel source/ destination in SSIS 2008 ?

I have got the below error when the excel is either source or destination along with OLEDB...

[Excel Destination [128]] Error: SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER. The AcquireConnection method call to the connection manager "Excel Connection Manager" failed with error code 0xC00F9304. There may be error messages posted before this with more information on why the AcquireConnection method call failed.


[Connection manager "Excel Connection Manager"] Error: SSIS Error Code DTS_E_OLEDB_EXCEL_NOT_SUPPORTED: The Excel Connection Manager is not supported in the 64-bit version of SSIS, as no OLE DB provider is available.

As the second error says it not supported 64 bit version, mine is SQL 2008 64 bit .

So is there any solution for this ?

Thanks & Regards,
MC
Koen Verbeeck
Koen Verbeeck
SSC Guru
SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)

Group: General Forum Members
Points: 60961 Visits: 13297
Well, the problem is quite obvious and the error message is quite clear:
no excel support for 64-bit. So it is not an error, it is by design :-)

Luckily, the solution is simple:
in SSIS 2008 BIDS, set the property Run64RunTime to false.
In SQL Server Agent you have the option in the SSIS job step to let the jobstep run in 32-bit.


How to post forum questions.
Need an answer? No, you need a question.
What’s the deal with Excel & SSIS?
My blog at SQLKover.

MCSE Business Intelligence - Microsoft Data Platform MVP
only4mithunc
only4mithunc
SSCommitted
SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)

Group: General Forum Members
Points: 1690 Visits: 2803
Hi thanks for the reply.

I had a look into the by right clicking the SQL Server Business Intelligence Development Studio -->Property --> Compatibility

There nothing is checked, is this is the one you specified below? I have attached the screenshot.

Thanks & Regards,
MC
Attachments
Compatibility settings.jpg (415 views, 78.00 KB)
only4mithunc
only4mithunc
SSCommitted
SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)

Group: General Forum Members
Points: 1690 Visits: 2803
Hey I under stood... I have made it to false now. it is working now...

Thanks lot mate... :-)

I have attached the screenshot might help some one else

Navigate to Project-->Properties-->Run64BitRuntime = False

Thanks & Regards,
MC
Attachments
Setting Run64Bitruntime to False.jpg (724 views, 82.00 KB)
nishav2
nishav2
Mr or Mrs. 500
Mr or Mrs. 500 (585 reputation)Mr or Mrs. 500 (585 reputation)Mr or Mrs. 500 (585 reputation)Mr or Mrs. 500 (585 reputation)Mr or Mrs. 500 (585 reputation)Mr or Mrs. 500 (585 reputation)Mr or Mrs. 500 (585 reputation)Mr or Mrs. 500 (585 reputation)

Group: General Forum Members
Points: 585 Visits: 103
Thanks a ton.I faced this issue today and I sorted out by seeing your screenshot..
namrata.dhanawade-1143388
namrata.dhanawade-1143388
Old Hand
Old Hand (317 reputation)Old Hand (317 reputation)Old Hand (317 reputation)Old Hand (317 reputation)Old Hand (317 reputation)Old Hand (317 reputation)Old Hand (317 reputation)Old Hand (317 reputation)

Group: General Forum Members
Points: 317 Visits: 205
This really helped!!

And as said, I hope I remember this when this problem crops up again.

Regards,
Namrata
Sqlalizer
Sqlalizer
Grasshopper
Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)Grasshopper (11 reputation)

Group: General Forum Members
Points: 11 Visits: 46
Thanks for this post. It helped me today as well- a full 4 years after you wrote it.
CptCrusty1
CptCrusty1
Say Hey Kid
Say Hey Kid (708 reputation)Say Hey Kid (708 reputation)Say Hey Kid (708 reputation)Say Hey Kid (708 reputation)Say Hey Kid (708 reputation)Say Hey Kid (708 reputation)Say Hey Kid (708 reputation)Say Hey Kid (708 reputation)

Group: General Forum Members
Points: 708 Visits: 387
I must be stupid. I'm not seeing it. Closest I get is Forced Execution Value Int32 or Int64.....
Koen Verbeeck
Koen Verbeeck
SSC Guru
SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)SSC Guru (60K reputation)

Group: General Forum Members
Points: 60961 Visits: 13297
CptCrusty1 (9/30/2015)
I must be stupid. I'm not seeing it. Closest I get is Forced Execution Value Int32 or Int64.....


You have to right-click on the SSIS project and go to properties.


How to post forum questions.
Need an answer? No, you need a question.
What’s the deal with Excel & SSIS?
My blog at SQLKover.

MCSE Business Intelligence - Microsoft Data Platform MVP
MMartin1
MMartin1
SSCertifiable
SSCertifiable (7.1K reputation)SSCertifiable (7.1K reputation)SSCertifiable (7.1K reputation)SSCertifiable (7.1K reputation)SSCertifiable (7.1K reputation)SSCertifiable (7.1K reputation)SSCertifiable (7.1K reputation)SSCertifiable (7.1K reputation)

Group: General Forum Members
Points: 7067 Visits: 2033
I dont exactly have SSIS 2005 handy, though in 2008 if it is not too different ...
Right click the project name in the solution explorer > properties > debugging ?(in 2008 at least) > run64bitRuntime <-- set this attribute to false.

----------------------------------------------------
How to post forum questions to get the best help
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search