Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Missing green arrow on the sql server icon in object explore


Missing green arrow on the sql server icon in object explore

Author
Message
DiggityShmoo
DiggityShmoo
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 166
I was having this problem on a development SQL server. Permissions were all correct, and i was able to manage the services remotely using the windows services management console, and the sql service configuration manager, but i was unable to view or modify the service status through the management studio.

The server I'm working on is going to replace an existing server, so it's currently running with a temporary hostname that isn't in DNS. This means I've had to connect to it using the IP address. I found that by adding the server to my hosts file and connecting by name instead of IP, i now get the green arrow and I can manage the instance through SSMS. Not sure why that makes a difference, but it worked for me!
Schadenfreude-Mei
Schadenfreude-Mei
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1129 Visits: 1336
DiggityShmoo (9/6/2011)
I was having this problem on a development SQL server. Permissions were all correct, and i was able to manage the services remotely using the windows services management console, and the sql service configuration manager, but i was unable to view or modify the service status through the management studio.

The server I'm working on is going to replace an existing server, so it's currently running with a temporary hostname that isn't in DNS. This means I've had to connect to it using the IP address. I found that by adding the server to my hosts file and connecting by name instead of IP, i now get the green arrow and I can manage the instance through SSMS. Not sure why that makes a difference, but it worked for me!


interesting. I'll give that a go later.

Adam Zacks

-------------------------------------------

Be Nice, Or Leave
Schadenfreude-Mei
Schadenfreude-Mei
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1129 Visits: 1336
Schadenfreude-Mei (9/7/2011)
DiggityShmoo (9/6/2011)
I was having this problem on a development SQL server. Permissions were all correct, and i was able to manage the services remotely using the windows services management console, and the sql service configuration manager, but i was unable to view or modify the service status through the management studio.

The server I'm working on is going to replace an existing server, so it's currently running with a temporary hostname that isn't in DNS. This means I've had to connect to it using the IP address. I found that by adding the server to my hosts file and connecting by name instead of IP, i now get the green arrow and I can manage the instance through SSMS. Not sure why that makes a difference, but it worked for me!


interesting. I'll give that a go later.


Sorry, no dice :-(

Adam Zacks

-------------------------------------------

Be Nice, Or Leave
DLathrop
DLathrop
SSC Journeyman
SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)

Group: General Forum Members
Points: 90 Visits: 219
I'm not sure if this is the correct answer; I've got the same lack of "server status" display on half of our servers, but haven't had time to pursue it myself.

According to BoL, WMI is used for the "Windows service level" monitoring and control for SQL Server. This is completely outside the SQL Server connection and permissions. There is a separate way to grant permissions for "remote access" to a server via WMI; check with your Windows sysadmin, and this is also documented in BoL (look under WMI).

SQL Agent can also define Alerts based on WMI, and SSIS has WMI query capabilities as well. SMO and PowerShell also use WMI for some of their server management functions. So its worth checking out.

David Lathrop
DBA
WA Dept of Health
Erik Edvalson
Erik Edvalson
Forum Newbie
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)

Group: General Forum Members
Points: 2 Visits: 7
I know that this thread has gone stale without replies for quite some time. However, I was having this same problem and I figured it out. This may or may not resolve the problem that the orginal poster had but here is what I had to do.

1. Open Control Panel and then double click the Windows Firewall icon to open the Windows Firewall control panel.
2. In the upper left, click Allow a program through Windows Firewall. This will open up the Windows Firewall Settings window.
3. Select the Exceptions tab, if it isn't already selected. Scroll down and make sure that Windows Management Instrumentation (WMI) is checked.
4. Click OK or Apply.

That's all I had to do. Hope this is helpful.
Schadenfreude-Mei
Schadenfreude-Mei
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1129 Visits: 1336
Erik Edvalson (1/14/2013)
I know that this thread has gone stale without replies for quite some time. However, I was having this same problem and I figured it out. This may or may not resolve the problem that the orginal poster had but here is what I had to do.

1. Open Control Panel and then double click the Windows Firewall icon to open the Windows Firewall control panel.
2. In the upper left, click Allow a program through Windows Firewall. This will open up the Windows Firewall Settings window.
3. Select the Exceptions tab, if it isn't already selected. Scroll down and make sure that Windows Management Instrumentation (WMI) is checked.
4. Click OK or Apply.

That's all I had to do. Hope this is helpful.


Thanks for this. We have since upgraded to ss2k8r2 and dont have 2k5 clusters anymore, so i cant test the solution. I am almost certain that the FW would have been off on all of the servers. And i have just checked my desktop pc to confirm, my FW is also off.

If the FW's were all off, would 'Exceptions' still be needed?

TIA,

Adam

Adam Zacks

-------------------------------------------

Be Nice, Or Leave
Noetic DBA
Noetic DBA
SSC-Addicted
SSC-Addicted (431 reputation)SSC-Addicted (431 reputation)SSC-Addicted (431 reputation)SSC-Addicted (431 reputation)SSC-Addicted (431 reputation)SSC-Addicted (431 reputation)SSC-Addicted (431 reputation)SSC-Addicted (431 reputation)

Group: General Forum Members
Points: 431 Visits: 419
I have this issue about once every 4 months. I pursued all of the permission issues and other things listed above. What I finally did was log into the SQL Server and restart the WMI service. This instantly fixed it. I see that your issue is probably more complicated than that, but several other people posted on this thread with the same issue and their fix might be that simple.
kevaburg
kevaburg
Mr or Mrs. 500
Mr or Mrs. 500 (563 reputation)Mr or Mrs. 500 (563 reputation)Mr or Mrs. 500 (563 reputation)Mr or Mrs. 500 (563 reputation)Mr or Mrs. 500 (563 reputation)Mr or Mrs. 500 (563 reputation)Mr or Mrs. 500 (563 reputation)Mr or Mrs. 500 (563 reputation)

Group: General Forum Members
Points: 563 Visits: 912
It is interesting because I have exactly the same problem as the original poster. I don't see a server state for all the machines to which i don't have Windows access but for all the machines to which I can log on (via RDP) I see the green indicator.

I can however view all the services running on the remote server when the green indicator is visible. Likewise, where I don't have Windows account access to the remote machine, I can't view the running services using the services snap-in!

In my case the problem lies with my inability to access the Windows Server with my Windows Domain-based account in order to view the services.
Super G
Super G
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 3
I have opened SSMS icon properties and checked "Run this program as an administrator" checkbox on "Compatibility" pannel.
Now when I run SSMS from this icon I can see server and Server agent status (green or red) and start, stop, restart etc. options are available in the menu.
norm688
norm688
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 113
I found this thread via google seach and the way I finally fixed it was adding myself to the administrators group on the windows servers that is hosting the SQL server...
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search