Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Missing green arrow on the sql server icon in object explore


Missing green arrow on the sql server icon in object explore

Author
Message
sqlnickxu
sqlnickxu
SSC-Enthusiastic
SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)

Group: General Forum Members
Points: 196 Visits: 942
'sa' is used for sql authentication. I assume this should have the highest privilege of all.

Bazinga!
SQLRNNR
SQLRNNR
SSC-Insane
SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)

Group: General Forum Members
Points: 21099 Visits: 18259
This issue frequently occurs if you do not have administrative permissions to stop, start, or restart services.


Verify that you have adequate permissions to start services on the server where sql is installed.



Jason AKA CirqueDeSQLeil
I have given a name to my pain...
MCM SQL Server, MVP


SQL RNNR

Posting Performance Based Questions - Gail Shaw

sqlnickxu
sqlnickxu
SSC-Enthusiastic
SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)

Group: General Forum Members
Points: 196 Visits: 942
I really don't want this thread sink in vain like all others that I can find from Google.

I used the 'sa' account and SQL Server authentication to connection from my workstation to the server and I believe 'sa' has sufficient privilege to start, stop or restart the SQL Server service.

I also tried remote desktop the server directly, log on to SSMS by 'sa' again and the green arrow appears fine.

Bazinga!
Animal Magic
Animal Magic
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1064 Visits: 13728
xnleiden (11/27/2009)
I really don't want this thread sink in vain like all others that I can find from Google.

I used the 'sa' account and SQL Server authentication to connection from my workstation to the server and I believe 'sa' has sufficient privilege to start, stop or restart the SQL Server service.

I also tried remote desktop the server directly, log on to SSMS by 'sa' again and the green arrow appears fine.


Its got nothing to do with being able to start/stop the services, its all to do with if your windows account has access to see the services state. go to start, run and type services.msc, change the machine name to the server your connecting to in ssms and see if you can see the sql services, i bet you wont be able too.
sqlnickxu
sqlnickxu
SSC-Enthusiastic
SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)

Group: General Forum Members
Points: 196 Visits: 942
Hello Animal Magic

I did try services.msc and connect it to the server and all start, stop and restart options are there for MSSQLSERVER service.

And the windows account I used for log on to my local workstation is a domain admin FYI.

Could you please advise me a bit more? Thanks.


Animal Magic (11/27/2009)
xnleiden (11/27/2009)
I really don't want this thread sink in vain like all others that I can find from Google.

I used the 'sa' account and SQL Server authentication to connection from my workstation to the server and I believe 'sa' has sufficient privilege to start, stop or restart the SQL Server service.

I also tried remote desktop the server directly, log on to SSMS by 'sa' again and the green arrow appears fine.


Its got nothing to do with being able to start/stop the services, its all to do with if your windows account has access to see the services state. go to start, run and type services.msc, change the machine name to the server your connecting to in ssms and see if you can see the sql services, i bet you wont be able too.


Bazinga!
Animal Magic
Animal Magic
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1064 Visits: 13728
ok thats interesting. does anyone else have SSMS on their machine, and if so is the service state missing for them too?

one other thing to try, connect to the server in SSMS using the IP address and see if you get the same result as with the server name
Schadenfreude-Mei
Schadenfreude-Mei
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1129 Visits: 1336
This might be a stupid question but are you running the SQL 2008 client?

I have found that for some reason, a SQL 2005 Ent 64-bit cluster state cannot be seen by the 2008 client (even if the windows account is a local admin of said node and cluster).

Aggree with Animal that providing your a local admin of the server your connecting to (and assuming there are no client incompatibilities) the server state should be reported fine.

Adam Zacks

-------------------------------------------

Be Nice, Or Leave
sqlnickxu
sqlnickxu
SSC-Enthusiastic
SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)SSC-Enthusiastic (196 reputation)

Group: General Forum Members
Points: 196 Visits: 942
Hello guys

Till now, I almost give up. I've tried probably everything that I can, using IP address directly for connection, make sure that my domain admin account is also in the administrator group on the server etc. But still no luck.

Bazinga!
SQLRNNR
SQLRNNR
SSC-Insane
SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)SSC-Insane (21K reputation)

Group: General Forum Members
Points: 21099 Visits: 18259
xnleiden (11/27/2009)
Hello Animal Magic

I did try services.msc and connect it to the server and all start, stop and restart options are there for MSSQLSERVER service.

And the windows account I used for log on to my local workstation is a domain admin FYI.

Could you please advise me a bit more? Thanks.



So you are able to start and stop services from the same account that launched SSMS, when you use services.msc?

What version of the Tools are you using?
Is this an issue for all SQL Instances?
Is the domain admin account the same account you are using to start sql services by chance?
Are the sql services using a domain account?
Do you have the same issue when connecting to the instance using your domain account via SSMS, and not SA?



Jason AKA CirqueDeSQLeil
I have given a name to my pain...
MCM SQL Server, MVP


SQL RNNR

Posting Performance Based Questions - Gail Shaw

Lynn Pettis
Lynn Pettis
SSC-Insane
SSC-Insane (24K reputation)SSC-Insane (24K reputation)SSC-Insane (24K reputation)SSC-Insane (24K reputation)SSC-Insane (24K reputation)SSC-Insane (24K reputation)SSC-Insane (24K reputation)SSC-Insane (24K reputation)

Group: General Forum Members
Points: 24233 Visits: 37978
I use a SQL account with admin access when working from home. I can't start and stop the SQL Server services using this account. If I need to, I remote in to my desktop at work and use my network id to access the servers and stop and start services from there.

I have an idea on how to change that, but haven't had the time to test it. Perhaps early next week I will, as I am not sure if I will have time this weekend.

Cool
Lynn Pettis

For better assistance in answering your questions, click here
For tips to get better help with Performance Problems, click here
For Running Totals and its variations, click here or when working with partitioned tables
For more about Tally Tables, click here
For more about Cross Tabs and Pivots, click here and here
Managing Transaction Logs

SQL Musings from the Desert Fountain Valley SQL (My Mirror Blog)
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search