SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


MSSQLServerOLAPService


MSSQLServerOLAPService

Author
Message
pavan.tns
pavan.tns
Old Hand
Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)

Group: General Forum Members
Points: 308 Visits: 56
I am getting the following error msgs every 10 seconds :
1)
The description for Event ID (2003) in Source (
MSSQLServerOLAPService) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: The event log file is corrupt..
2)
The Open Procedure for source "MSSQLServerOLAPService" in DLL "C:\Program Files\Microsoft Analysis Services\Bin\msmdctr80.dll" failed.
Performance data for this service will not be available. Status code returned is data DWORD 0.

These errors are on SQL SERVER 2000 with SP4.

Any help in this regards .....
Joie Andrew
Joie Andrew
One Orange Chip
One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)

Group: General Forum Members
Points: 25810 Visits: 2133
Do you have any analysis services that are failing? OLAP is for analytical processing, so it would be needed it you were running anything like a data warehouse. If you look at the properties of the service on Computer Manager, is it set to restart the service after 1st, 2nd and subsequent failures? That may help explain why you are getting an error message every 10 seconds.

Joie Andrew
"Since 1982"
pavan.tns
pavan.tns
Old Hand
Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)

Group: General Forum Members
Points: 308 Visits: 56
Yes, it has sql agent job which stops and starts the service. But this job is failing these days.
The service is set to automatic start up. 1st step of the job is to stop the service, 2nd step is to wait for 30 seconds, 3rd step is to start the service again. It is using netstart and netstop commands.

so, this job is failing in its 3rd step daily.

what is the work around for this, any resolution?
Joie Andrew
Joie Andrew
One Orange Chip
One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)One Orange Chip (25K reputation)

Group: General Forum Members
Points: 25810 Visits: 2133
I am not that experienced with Analysis Services, especially on SQL 2000, but it seems strange that a SQL Agent would have a job that just starts the service. Does the service stop to allow another job to run at that time?

As for your error, it sounds like a file is missing that is needed for the service. Does the .dll file that the error you posted was talking about exist in the location listed in the error? Does the account that is running the job have permissions to that directory/file?

Joie Andrew
"Since 1982"
sandeep-407903
sandeep-407903
SSC Rookie
SSC Rookie (45 reputation)SSC Rookie (45 reputation)SSC Rookie (45 reputation)SSC Rookie (45 reputation)SSC Rookie (45 reputation)SSC Rookie (45 reputation)SSC Rookie (45 reputation)SSC Rookie (45 reputation)

Group: General Forum Members
Points: 45 Visits: 28
I believe that the job issue has been sorted out now!.. for this error check this link
http://www.eventid.net/display.asp?eventid=1008&eventno=70&source=Perflib&phase=1
pavan.tns
pavan.tns
Old Hand
Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)

Group: General Forum Members
Points: 308 Visits: 56
The thing is should I ignore this ?
pavan.tns
pavan.tns
Old Hand
Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)Old Hand (308 reputation)

Group: General Forum Members
Points: 308 Visits: 56
No the problem still exists..
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum









































































































































































SQLServerCentral


Search