Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


The column "Column 2" cannot be processed because more than one code page (65001 and 1252) are...


The column "Column 2" cannot be processed because more than one code page (65001 and 1252) are specified for it.

Author
Message
winston Smith
winston Smith
SSC Eights!
SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)

Group: General Forum Members
Points: 981 Visits: 2040
I get this error if i try to import a tab delimited flat file to a table in sql server.

The column "Column 2" cannot be processed because more than one code page (65001 and 1252) are specified for it.


I have set the "alwaysUseDefaultCodePage" property of the destination connection to True.
There is no such property for the flatfile source connection.

I have gotten around it by setting the codepage property of the OLEDB connection to 65001 but i dont know what this did or why it worked.

What does this error mean?
Is it a bug or is it serving a usefull purpose?
Why did my "workaround" work?



Thanks!
madhukeshwark
madhukeshwark
Grasshopper
Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)

Group: General Forum Members
Points: 21 Visits: 79
Hi Winston Smith !
As per my understanding, u have set the flat file connection manager configuration setting correctly. You need to specify the delimiter in the connection manager.
Pls let me know which tasks u r using to achieve this task?
winston Smith
winston Smith
SSC Eights!
SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)SSC Eights! (981 reputation)

Group: General Forum Members
Points: 981 Visits: 2040
madhukeshwark (8/22/2009)
Hi Winston Smith !
As per my understanding, u have set the flat file connection manager configuration setting correctly. You need to specify the delimiter in the connection manager.
Pls let me know which tasks u r using to achieve this task?


Hi.

I think you misread my post. I didnt change anything for the flatfile connection as the flag was not present. what i changed was:

1. I have set the "alwaysUseDefaultCodePage" property of the destination OLEDB connection to True.
2. I have set the codepage property of the OLEDB connection to 65001

This allowed the package to work but I would really like to understand what a code page is, why this error presents its self so often, if its a bug and if not, what usefullness does it provide.

Regarding what im using, i simply have a flat file connection feeding to a OLEDB destination connection
BaldingLoopMan
BaldingLoopMan
Old Hand
Old Hand (312 reputation)Old Hand (312 reputation)Old Hand (312 reputation)Old Hand (312 reputation)Old Hand (312 reputation)Old Hand (312 reputation)Old Hand (312 reputation)Old Hand (312 reputation)

Group: General Forum Members
Points: 312 Visits: 457
i had the same issue except i was conn to sql server.

i had to delete everything and rebuild it with my flat file code page to = 1252 and it worked.
v-hymag
v-hymag
Valued Member
Valued Member (58 reputation)Valued Member (58 reputation)Valued Member (58 reputation)Valued Member (58 reputation)Valued Member (58 reputation)Valued Member (58 reputation)Valued Member (58 reputation)Valued Member (58 reputation)

Group: General Forum Members
Points: 58 Visits: 39
Hi;

CODE PAGE BACKGROUND:-

I was working with one SSIS package and created a second package that would use some of the configured controls from the first package. By copying controls from the first package to the second package, I ended up with several controls using the page number from its source. So, when I attempted to debug the second package I received the following message:

The "column1" cannot be processed because more than one code page (1252 and 65001) are specified for it.

In short the first SSIS package had a page number of 1252 and the second SSIS package had a page number of 65001. So all of the controls copied from the first package retained their 1252 page number references.



SOLUTION 1:-
1. I edited the metadata code-behind by replacing all 1252 page number references with 65001.
2:- setting "AlwaysUseDefaultCodePage" property of oledb source as true.

Summary:-
While building SSIS packages graphically within VS 2005 design mode, a metadata code behind page is modified to reflect the graphical controls used within the designer. It is here within the metadata code-behind where controls reference their parent page with a page number. Each SSIS package has a code-behind with a default page number. Different SSIS packages should have different page numbers.
vgv8
vgv8
Grasshopper
Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)

Group: General Forum Members
Points: 19 Visits: 90
having same in the same SSIS package

I also would like to understand where is the phantom codepage for and why
vgv8
vgv8
Grasshopper
Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)Grasshopper (19 reputation)

Group: General Forum Members
Points: 19 Visits: 90
IMO, this is obvious and very annoying bug
which I reported
https://connect.microsoft.com/SQLServer/feedback/details/566945/bids-inserts-fanthom-code-page-s-into-ssis-2008-r2-components-irrelevant-to-format-locales-codepages-of-data-and-software-used-blocking-the-ssis-tasks

No, response whatsoever in 2 weeks
I guess from my previous experiences with ingenuous "conveniences" in MS products,
it will be closed "by design"
http://social.msdn.microsoft.com/Forums/en/sqlintegrationservices/thread/f6717d6d-3ffb-426f-8a82-96e1e3d131d8
koushaljha
koushaljha
Forum Newbie
Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)

Group: General Forum Members
Points: 7 Visits: 14
I faced this issue , and just delete the existing source file (.csv) connection and re-create it. it get fresh code page 1252.
koushaljha
koushaljha
Forum Newbie
Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)

Group: General Forum Members
Points: 7 Visits: 14
[b]I faced this issue , and just delete the existing source file (.csv) connection and re-create it. it get fresh code page 1252.:-)
Michael G
Michael G
SSC Veteran
SSC Veteran (234 reputation)SSC Veteran (234 reputation)SSC Veteran (234 reputation)SSC Veteran (234 reputation)SSC Veteran (234 reputation)SSC Veteran (234 reputation)SSC Veteran (234 reputation)SSC Veteran (234 reputation)

Group: General Forum Members
Points: 234 Visits: 153
I've just encountered this bug too.
What caused it was I edited a package by deleting the Excel source and replaced it with a .rpt flat file source... then all hell broke loose :-D

The only way I managed to fix it (after an hour or so of browsing between the source and target's trees and messing with the codepages) was to delete my Derived Column and OLE DB Destination.

I'm about to press run, wish me luck.

Michael Gilchrist
Database Specialist
There are 10 types of people in the world, those who understand binary and those that don't. :-D
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search