SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


renaming a server


renaming a server

Author
Message
cruci8
cruci8
SSC Veteran
SSC Veteran (223 reputation)SSC Veteran (223 reputation)SSC Veteran (223 reputation)SSC Veteran (223 reputation)SSC Veteran (223 reputation)SSC Veteran (223 reputation)SSC Veteran (223 reputation)SSC Veteran (223 reputation)

Group: General Forum Members
Points: 223 Visits: 557
Try dropping the distribution database via the cleanup sp, this effectively runs the menu command 'Remove Publishing and Distribution' but bypasses the checking. Run

USE master
GO
EXEC sp_dropdistributor @no_checks = 1
GO

You should then be able to rename your SQL server with

EXEC sp_dropserver ''
GO
EXEC sp_addserver '', 'local'
GO

but don't forget to restart the services or it won't take effect.
sqlGDBA
sqlGDBA
Ten Centuries
Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)

Group: General Forum Members
Points: 1349 Visits: 349
The Quest e-book , page #77 was an excellent tip. I have a crappy network that seems to decide on it's own whether DNS works or not. I had to rename the server to the FQDN, and couldnt because of replication which had linked server logins.

Thanks Jamie !!
@STLSQLGuy
@STLSQLGuy
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1074 Visits: 209
If you are getting this error because of sticky points due to replication run this:

sp_dropdistpublisher 'bad server name'

that should clear up the name mismatch on replication and allow you to change your server name as you noted in the origional post.


thanks, ERH

duvvit
duvvit
SSC Journeyman
SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)

Group: General Forum Members
Points: 90 Visits: 89
I tried the disable of the publishing, but it still would not allow the connection to the alias.
I ended up changing the server name back on the network, disabling replication, then dropping server and adding server as new name.
duvvit
duvvit
SSC Journeyman
SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)SSC Journeyman (90 reputation)

Group: General Forum Members
Points: 90 Visits: 89
THIS, worked for me:

select @@servername

sp_helpserver

sp_helpremotelogin 'xxxx'

--sp_dropremotelogin 'xxxx','DOMAIN\account'
--sp_dropremotelogin 'xxxx'
--sp_dropserver 'xxxx'

sp_dropserver 'xxxx', 'droplogins'
sp_addserver 'xxxx-new', local
Wayne Erfling
Wayne Erfling
SSC Journeyman
SSC Journeyman (97 reputation)SSC Journeyman (97 reputation)SSC Journeyman (97 reputation)SSC Journeyman (97 reputation)SSC Journeyman (97 reputation)SSC Journeyman (97 reputation)SSC Journeyman (97 reputation)SSC Journeyman (97 reputation)

Group: General Forum Members
Points: 97 Visits: 97
I can report that the "alias" approach works where replication cannot be otherwise disabled.

I had wondered how deeply in the code aliases were utilized, as I've been using them quite superficially until now.

Thanks!
makarov
makarov
SSC Rookie
SSC Rookie (30 reputation)SSC Rookie (30 reputation)SSC Rookie (30 reputation)SSC Rookie (30 reputation)SSC Rookie (30 reputation)SSC Rookie (30 reputation)SSC Rookie (30 reputation)SSC Rookie (30 reputation)

Group: General Forum Members
Points: 30 Visits: 132
this worked for me thanks!
gunna48
gunna48
SSC-Enthusiastic
SSC-Enthusiastic (100 reputation)SSC-Enthusiastic (100 reputation)SSC-Enthusiastic (100 reputation)SSC-Enthusiastic (100 reputation)SSC-Enthusiastic (100 reputation)SSC-Enthusiastic (100 reputation)SSC-Enthusiastic (100 reputation)SSC-Enthusiastic (100 reputation)

Group: General Forum Members
Points: 100 Visits: 184
Worked like a charm Thanks Luis! Satisfied
cneal 83563
cneal 83563
SSC-Enthusiastic
SSC-Enthusiastic (106 reputation)SSC-Enthusiastic (106 reputation)SSC-Enthusiastic (106 reputation)SSC-Enthusiastic (106 reputation)SSC-Enthusiastic (106 reputation)SSC-Enthusiastic (106 reputation)SSC-Enthusiastic (106 reputation)SSC-Enthusiastic (106 reputation)

Group: General Forum Members
Points: 106 Visits: 326
Wow thanks Luis that worked!!!
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search