SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Database Mail


Database Mail

Author
Message
tfifield
tfifield
SSCrazy
SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)

Group: General Forum Members
Points: 2461 Visits: 2890
I had DB Mail working properly while using our ISP as the SMTP server. We switched to Google business mail - the free version and now I can't get it to work no matter what I do. The reason we switched was that some emails got lost and the ISP wouldn't give us enough disk space for the accounts.

I've tried Anonymous authentication, Basic Authenticaion using the same email address and password that is authenticated at Google. I've tried changing the SMTP port to 465 from 25. I've tried checking and unchecking the Requires SSL Connection. All results are the same with the same message:

The mail could not be sent to the recipients because of the mail server failure. (Sending Mail using Account 1 (2008-08-03T11:41:19). Exception Message: Cannot send mails to mail server. (The operation has timed out.). Sending Mail using Account 1 (2008-08-03T11:43:09). Exception Message: Cannot send mails to mail server. (The operation has timed out.). )

I'm thinking that Google has some sort of SPAM filtering going on or possibly there is a reverse lookup problem with the domain name.

Has anyone had this problem and solved it?
Todd Fifield
sqlizer
sqlizer
Right there with Babe
Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)

Group: General Forum Members
Points: 794 Visits: 628
Use Port # 587 instead of 465. Also use SSL and you need to enter your gmail account info while configuring the DB mail using gmail. Enter your both account credential "username@gmail.com" and "password".
tfifield
tfifield
SSCrazy
SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)

Group: General Forum Members
Points: 2461 Visits: 2890
Chintan,
Thanks for the advice. I'll try the port change today.

I'm a little confused at the 'username@gmail.com' advice. We use the business feature where our domain name is part of the EMail address. The EMail address to the outside is:
info@ourdomain.com

This actually resolves to:
mail.google.com/a/ourdomain

I've been using info@ourdomain.com as the sender and replyto EMail address.
Todd Fifield
sqlizer
sqlizer
Right there with Babe
Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)Right there with Babe (794 reputation)

Group: General Forum Members
Points: 794 Visits: 628
todd,

i have been configuring my home machine with free Gmail account and it's been working fine. I have never used gmail business account so frankly speaking i don't know how it works. I think then you just need to change the port, select SSL and enter your business account info in and i hope it will work.

good luck
Drushen
Drushen
Forum Newbie
Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)Forum Newbie (9 reputation)

Group: General Forum Members
Points: 9 Visits: 9
Hi Did you find a solution to your problem. I am having the exact same problem. I am a newbie to SQL server 2008, but I did configure it to work the first time. After SP 1 2008 for sql server, I subsequently ran into problems and had to create a new instance. I have tried all possible settings in Database mail configuration utility. In parameters i increased the time out period, but still no luck
The error message in the log file


The mail could not be sent to the recipients because of the mail server failure. (Sending Mail using Account 2 (2009-04-30T12:25:17). Exception Message: Cannot send mails to mail server. (The operation has timed out.)


I have configured sql server agent to use my database mail profile.
tfifield
tfifield
SSCrazy
SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)SSCrazy (2.5K reputation)

Group: General Forum Members
Points: 2461 Visits: 2890
Drushen,
I never did get a solution for GMail. What we ended up doing was set up a Linux box running Zimbra to use as the SMTP server. The only thing the box was used for was Database Mail. It's been working for may months now.
Todd
SQLQuest29
SQLQuest29
SSCrazy
SSCrazy (2.1K reputation)SSCrazy (2.1K reputation)SSCrazy (2.1K reputation)SSCrazy (2.1K reputation)SSCrazy (2.1K reputation)SSCrazy (2.1K reputation)SSCrazy (2.1K reputation)SSCrazy (2.1K reputation)

Group: General Forum Members
Points: 2145 Visits: 4367
Todd,

Try the following:

account name: your SQL server instance name
PORT: let it be the default
smtp: your smtp server name (smoething like smtp.gmail.com)
authentication: use any (like windows, SQL server or any)


The only trick is the account name and the smtp account. I had problems trying to send mail using database mail to my gmail account, but trying this will work out.

Let me know how it worked out or if u have any errors post the steps u did and the error message.

Hope this helps,

\\K :-)

______________________________________________________________________________________________________________________________________________________________________________________
HTH !
Kin
MCTS : 2005, 2008
Active SQL Server Community Contributor :-)
parmindermehta
parmindermehta
SSC Rookie
SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)

Group: General Forum Members
Points: 31 Visits: 9
Hi friends,

I used the following settings to make free gmail account working for me in Database Mail.

Outgoing mail server (SMTP)

Email address: gmailID@gmail.com
Display name: Name you like others to know that email came from.
Reply e-mail: can be same as Email mentioned above or some other email id.
Server name: smtp.gmail.com
Port No: 587

SMTP Authentication: -

Select Basic Authentication
User name: GMailID
Password: Your GMail ID password
Confirm password: Same as above


Save the above settings and hopefully it will work for you as it worked for me.

Good luck,
Parminder
parmindermehta
parmindermehta
SSC Rookie
SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)

Group: General Forum Members
Points: 31 Visits: 9
In my last reply to this post, I forgot to mention to also select - "This server requires a secure connection (SSL)".

Sorry for the inconvenience.

Thanks,
Parminder
FlorinManea
FlorinManea
SSC Rookie
SSC Rookie (28 reputation)SSC Rookie (28 reputation)SSC Rookie (28 reputation)SSC Rookie (28 reputation)SSC Rookie (28 reputation)SSC Rookie (28 reputation)SSC Rookie (28 reputation)SSC Rookie (28 reputation)

Group: General Forum Members
Points: 28 Visits: 12
Thanks man, you saved my day.
Indeed, the smtp port for gmail must be 587

Best,
F
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search