SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


I need to reinstall the Sql Server 2005 Agent


I need to reinstall the Sql Server 2005 Agent

Author
Message
pucitrabbani
pucitrabbani
SSC Rookie
SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)

Group: General Forum Members
Points: 31 Visits: 7
when i run this command it gives the result 'Running'
but the agent is not still visible... for ur convineous , i send u image of the screen as bellow..
so please help me out it will clear to u that what probelm aactual is...
thanks in advance...
GilaMonster
GilaMonster
SSC Guru
SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)

Group: General Forum Members
Points: 86836 Visits: 45257
I can't see your hard drive. Image url - file:///h:/sql.bmp
Attach a jpg to your post.

SQL agent is installed and is running. Are you sysadmin on that server?

Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass


pucitrabbani
pucitrabbani
SSC Rookie
SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)SSC Rookie (31 reputation)

Group: General Forum Members
Points: 31 Visits: 7
i m a system administrator. the print screen image is attached with it.
thanks in advance
Attachments
sql.JPG (46 views, 92.00 KB)
GilaMonster
GilaMonster
SSC Guru
SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)

Group: General Forum Members
Points: 86836 Visits: 45257
Try connecting from full management studio, rather than management studio express.

You can install the workstation componenents alone on your client PC from the same DVD that you installed the server.

btw, you may want to patch those servers. SQL 2000 unpatched (testsys 8.0.194) is a massive security risk. SQL 2005 unpatched is a lot better, but there were bugs in the RTM version. Current patch level is SP2.

Gail Shaw
Microsoft Certified Master: SQL Server, MVP, M.Sc (Comp Sci)
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass


Geoff A
Geoff A
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1072 Visits: 1802
im going to post this because google brought me here and there was no answer. Now, i have an answer so i will share....

my agent also disappeared from an install of SQL 2005. The reason is not known for 100% sure, but i believe it was from a SQL 2008 upgrade that was rolled back to SQL 2005. I could be wrong, but I did in fact end up with a perfect SQL engine and no agent. The solution was to recreate the service like this;

C:\>sc create SQLAgent binPath= "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\SQLAGENT90.EXE" type= own start= auto depend= netbios

after i started the newly created service, my SQL jobs started working again without issue. (i also changed the account that runs the service from "local account" to a domain admin account)
KoldCoffee
KoldCoffee
SSCommitted
SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)

Group: General Forum Members
Points: 1525 Visits: 1905
I came to this post for similar issue: SQL Server Agent not running on Enterprise edition.
Above recommendation helped. I found service was not started and wouldn't start until I added 'Administrator' into 'Log On' dialogue window. First R-click on the service and then go to Log On tab...
Now SQL Server Agent is running for me. thanks.
Helen
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search