SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


how to set the 'Select All' option as default selected in multivalue parameter?


how to set the 'Select All' option as default selected in multivalue parameter?

Author
Message
Mike Nowill
Mike Nowill
SSCommitted
SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)

Group: General Forum Members
Points: 1502 Visits: 623
mtraphagen:

If you want a default select for your parameters then you can set that up in the "Default values" section at the bottom of the "Report parameters" screen. If you want just one value chosen then you can use the "non-queried" option. for example, if you wanted toady's date selected then you would enter "=today()". If you want to select a bunch of stuff (or everything) from a query then you can do that with the "From query" option. It will ask you for a dataset and and a value field that matches the value field from the "available values" section.
mtraphagen
mtraphagen
SSC-Enthusiastic
SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)

Group: General Forum Members
Points: 139 Visits: 70
Hi Mike,

I'm missing something really obvious. (Sorry) it sounds as if I'm doing precisely what you describe, but my check boxes are not checked by default.

In avail values: From query, a dataset I've created just for this list. Value\label fields selected from this list.

Default values; From Query. I've tried both the main dataset and the list dataset. Neither sets my check boxes. (Actually, main dataset errors out.)

SQL Server 2005 is on the server with SP2. I'm using VS2005 on my dev box. I never upgraded the server from previous. I built it last month then applied SP2.

any ideas what I'm doing wrong?

Thank you a whole bunch!

Michelle
Mike Nowill
Mike Nowill
SSCommitted
SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)

Group: General Forum Members
Points: 1502 Visits: 623
Hey Michelle,

Your "default value" should be identical to your "available values" settings and it should work just fine. Have you tried it in both VS and SSRS?
mtraphagen
mtraphagen
SSC-Enthusiastic
SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)

Group: General Forum Members
Points: 139 Visits: 70
I want to select a bunch of stuff (or everything) from a query then you can do that with the "From query" option. It will ask you for a dataset and and a value field that matches the value field from the "available values" section.

...I did that, my values display, but none are checked. I have no idea what I am missing.....

Sad
mtraphagen
mtraphagen
SSC-Enthusiastic
SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)

Group: General Forum Members
Points: 139 Visits: 70
Hi,

I'm using VS2005. I'm deploying to Sharepoint so I can't use SSRS right? Or do you mean Report Builder? Report Builder won't open up my VS2005 created reports.
Mike Nowill
Mike Nowill
SSCommitted
SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)SSCommitted (1.5K reputation)

Group: General Forum Members
Points: 1502 Visits: 623
Hey Michelle,

I was just curious if this issue was specific to VS or also apparent in RS/MOSS.

Question: Is the "Multi-value" options checked under properties?
Matt Miller (4)
Matt Miller (4)
One Orange Chip
One Orange Chip (29K reputation)One Orange Chip (29K reputation)One Orange Chip (29K reputation)One Orange Chip (29K reputation)One Orange Chip (29K reputation)One Orange Chip (29K reputation)One Orange Chip (29K reputation)One Orange Chip (29K reputation)

Group: General Forum Members
Points: 29551 Visits: 19006
mtraphagen (5/20/2008)
I want to select a bunch of stuff (or everything) from a query then you can do that with the "From query" option. It will ask you for a dataset and and a value field that matches the value field from the "available values" section.

...I did that, my values display, but none are checked. I have no idea what I am missing.....

Sad


You have to repeat that below in the "default value" section. It doesn't show anything at first, since the default "default" is null. You'll want to set it to the same thing as the value column you have in the "Available values" section.

----------------------------------------------------------------------------------
Your lack of planning does not constitute an emergency on my part...unless you're my manager...or a director and above...or a really loud-spoken end-user..All right - what was my emergency again?
mtraphagen
mtraphagen
SSC-Enthusiastic
SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)SSC-Enthusiastic (139 reputation)

Group: General Forum Members
Points: 139 Visits: 70
Hey!

I had to go into MOSS, into the edit parameter option and set the default there. (Yuk, not fun if you have a bunch of them)

But it worked for me then. My values are checked by default! Thank you very much!


I appreciate it!

Michelle
shathaway 77080
shathaway 77080
SSC-Enthusiastic
SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)

Group: General Forum Members
Points: 193 Visits: 29
How/where in MOSS did you go to edit the parameter option.

I have having the same issues where my default values are setup the same as my available values, multiple selections is checked, but no values are checked in the parameter list.

Thank you,


Steve

mtraphagen (5/20/2008)
Hey!

I had to go into MOSS, into the edit parameter option and set the default there. (Yuk, not fun if you have a bunch of them)

But it worked for me then. My values are checked by default! Thank you very much!


I appreciate it!

Michelle

shathaway 77080
shathaway 77080
SSC-Enthusiastic
SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)SSC-Enthusiastic (193 reputation)

Group: General Forum Members
Points: 193 Visits: 29
I figured it out. My query on the parameter list dataset was returning a NULL value in the list. This is not supported. After I added the where programname <> 'NULL' to the dataset query, everything is working now and the values are all selected by default.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search