SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Page Break problem in reporting services when I use matrix


Page Break problem in reporting services when I use matrix

Author
Message
kalyan-413428
kalyan-413428
Forum Newbie
Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)

Group: General Forum Members
Points: 5 Visits: 1

Hi,

I have the blank page problem in my report. In the report I have a table with contains 50 rows so the table will be printed in two pages and after the table I have matrix and the columns in the matrix are not common. The problem is that if the number of columns in the matrix is greater than 10 then it prints the remaining columns in the next page but at the same I am getting the blank pages in the first table i.e between 1st and 2nd page .

How can I delete the blank pages.

Kalyan


Kevin Mao-243787
Kevin Mao-243787
SSC-Enthusiastic
SSC-Enthusiastic (198 reputation)SSC-Enthusiastic (198 reputation)SSC-Enthusiastic (198 reputation)SSC-Enthusiastic (198 reputation)SSC-Enthusiastic (198 reputation)SSC-Enthusiastic (198 reputation)SSC-Enthusiastic (198 reputation)SSC-Enthusiastic (198 reputation)

Group: General Forum Members
Points: 198 Visits: 183

Hi, Kalyan

Could you ensure no much extra space below right and bottom of the matrix?

Attached a sample. Hope it will solve your problem. Kevin


adeeb_nlv
adeeb_nlv
Grasshopper
Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)

Group: General Forum Members
Points: 21 Visits: 2
Hi
I'm facing the same problem.

The Matrix I'm using has one static row and a dynamic row that ranges from 10 to say 15 columns. The report is in portrait format to accommodate the columns. Although the number of columns is high, all the columns are displayed on the same page. The problem is that each page is followed by a blank page when I export the report to .pdf. I haven't tried any other format because I need to export the data to specifically a pdf.
In design mode there is a large white space to the right of the matrix. A simple solution is to reduce the white space by pulling the margin closer to the matrix, but doing this is disturbing the look of the report. The report has a header which just doesn't sit well with the rest of the report when I drag the border down.

I guess I'm asking too much here but what I want is for SSRS to ignore the white spaces to the right of the matrix. Any ideas how I can get about doing this.
adeeb_nlv
adeeb_nlv
Grasshopper
Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)

Group: General Forum Members
Points: 21 Visits: 2
I found a solution to the problem, a work around actually.

I made a second report of the matrix table I was having the problem with and used it as a subreport in the main report. I max'd out the width of the subreport control as much as landscape mode allows and Voila! I am suffering from horizontal page breaks no more.

Thank Anyway
dj1202
dj1202
SSC-Enthusiastic
SSC-Enthusiastic (143 reputation)SSC-Enthusiastic (143 reputation)SSC-Enthusiastic (143 reputation)SSC-Enthusiastic (143 reputation)SSC-Enthusiastic (143 reputation)SSC-Enthusiastic (143 reputation)SSC-Enthusiastic (143 reputation)SSC-Enthusiastic (143 reputation)

Group: General Forum Members
Points: 143 Visits: 231
That was a clever solution you found. I've also experienced this issue before, as it is quite common. Sometimes I've found the solution to lie in setting the "ConsumeContainerWhiteSpace" property to "True" in the Report properties. Also, playing with the margins or using Landscape layout can help. Thanks for sharing your solution.
adeeb_nlv
adeeb_nlv
Grasshopper
Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)Grasshopper (21 reputation)

Group: General Forum Members
Points: 21 Visits: 2
"ConsumeContainerWhiteSpace" sounds like the solution I wanted. I'll keep it in mind for future use. Thank you for replying.
Deepak Gupta
Deepak Gupta
Forum Newbie
Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)Forum Newbie (5 reputation)

Group: General Forum Members
Points: 5 Visits: 22
After trying out all options (ensuring Body width is less than Report + Margins, putting the Tablix in a rectangle, etc), setting the ConsumeContainerWhiteSpace to TRUE worked for me.

Thanks!
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search