SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Getting error when setting up subscription


Getting error when setting up subscription

Author
Message
sqlstar2011
sqlstar2011
Ten Centuries
Ten Centuries (1.4K reputation)Ten Centuries (1.4K reputation)Ten Centuries (1.4K reputation)Ten Centuries (1.4K reputation)Ten Centuries (1.4K reputation)Ten Centuries (1.4K reputation)Ten Centuries (1.4K reputation)Ten Centuries (1.4K reputation)

Group: General Forum Members
Points: 1355 Visits: 592

I get the following error when setting up subscription:

Creating Subscription(s)...

- Creating subscription for 'CISSW-YUKON04' (Warning)

Messages

Unable to set the Publisher login for the updatable subscription. You may have to set this up directly on the Subscriber machine using sp_link_publication. (New Subscription Wizard)

------------------------------
ADDITIONAL INFORMATION:

An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

------------------------------

The security mode specified requires the server 'CISSW-YUKON03' in sysservers. Use sp_addlinkedserver to add the server.
Changed database context to 'ReportServer'. (Microsoft SQL Server, Error: 20620)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=09.00.2047&EvtSrc=MSSQLServer&EvtID=20620&LinkId=20476

any ideas?

thanks


debrucer1
debrucer1
Ten Centuries
Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)Ten Centuries (1.3K reputation)

Group: General Forum Members
Points: 1322 Visits: 136

I would start by seeing what is currently in sysservers... and if the desired server is not there, I would use the sp_addlinkedserver procedure they name in the message to get it there...

are you replicating the reportserver db? How interesting.

I didn't bother to follow the link... did you?

Let us know how you fixed it.



Thanks,

David Russell
Oracle Since 1982
SQL Server Since 1998
deepika.sharma-632099
deepika.sharma-632099
Forum Newbie
Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)

Group: General Forum Members
Points: 8 Visits: 32
i m getting following error

unable to set the Publisher login for the updatable subscription. You may have to set this up directly on the Subscriber machine using sp_link_publication.

ADDITIONAL INFORMATION: An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo) The operation could not be performed because OLE DB provider "SQLNCLI" for linked server "REPLLINK_PRODSK0474-830409266_NETSOFT967703635_PUBLISHER-2139572905_NETSOFTSUB1650910173" was unable to begin a distributed transaction. Changed database context to 'NetSoftSubscriber'. OLE DB provider "SQLNCLI" for linked server "REPLLINK_PRODSK0474-830409266_NETSOFT967703635_PUBLISHER-2139572905_NETSOFTSUB1650910173" returned message "The partner transaction manager has disabled its support for remote/network transactions.". (Microsoft SQL Server, Error: 7391)

can anyone help??
sram24_mca
sram24_mca
Mr or Mrs. 500
Mr or Mrs. 500 (566 reputation)Mr or Mrs. 500 (566 reputation)Mr or Mrs. 500 (566 reputation)Mr or Mrs. 500 (566 reputation)Mr or Mrs. 500 (566 reputation)Mr or Mrs. 500 (566 reputation)Mr or Mrs. 500 (566 reputation)Mr or Mrs. 500 (566 reputation)

Group: General Forum Members
Points: 566 Visits: 508
Hi,
Can you check the network configuration in SQLSERVER surface area configuration whether all the services is having the remote connection permission or not.

Regards,
ram
sandeep.chandi
sandeep.chandi
Grasshopper
Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)Grasshopper (23 reputation)

Group: General Forum Members
Points: 23 Visits: 51
Hi all,
When i do replication from the same machine on different instances it works fine. But between different machines it gives the same error as mentionend in the previous post.
Everything related to remote connections has been enabled on both the servers. I have added both servers in Linked server lists of each other as well.

Please help as soon as possible.

Regards
deepika.sharma-632099
deepika.sharma-632099
Forum Newbie
Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)Forum Newbie (8 reputation)

Group: General Forum Members
Points: 8 Visits: 32
my issue got resolved by following step:
To allow the network transaction, you must enable MSDTC. To do this, follow these steps: a. Click Start, and then click Run.
b. In the Run dialog box, type dcomcnfg.exe, and then click OK.
c. In the Component Services window, expand Component Services, expand Computers, and then expand My Computer.
d. Right-click My Computer, and then click Properties.
e. In the My Computer Properties dialog box, click Security Configuration on the MSDTC tab.
f. In the Security Configuration dialog box, click to select the Network DTC Access check box.
g. To allow the distributed transaction to run on this computer from a remote computer, click to select the Allow Inbound check box.
h. To allow the distributed transaction to run on a remote computer from this computer, click to select the Allow Outbound check box.
i. Under the Transaction Manager Communication group, click to select the No Authentication Required option.
j. In the Security Configuration dialog box, click OK.
k. In the My Computer Properties dialog box, click OK.
source: http://support.microsoft.com/?kbid=873160
AnilT
AnilT
Valued Member
Valued Member (56 reputation)Valued Member (56 reputation)Valued Member (56 reputation)Valued Member (56 reputation)Valued Member (56 reputation)Valued Member (56 reputation)Valued Member (56 reputation)Valued Member (56 reputation)

Group: General Forum Members
Points: 56 Visits: 86
I have had exactly the same problem, now solved thanks to your post.

Anil



Gunjan
Gunjan
Right there with Babe
Right there with Babe (788 reputation)Right there with Babe (788 reputation)Right there with Babe (788 reputation)Right there with Babe (788 reputation)Right there with Babe (788 reputation)Right there with Babe (788 reputation)Right there with Babe (788 reputation)Right there with Babe (788 reputation)

Group: General Forum Members
Points: 788 Visits: 309
I am using getting the following error

INSERT TempErrorDetailsParameters Exec DBServer.DBName.dbo.GetEmployees '03/01/2008','03/31/2008'

OLE DB provider "SQLNCLI" for linked server "DBServer" returned message "No transaction is active.".
Msg 7391, Level 16, State 2, Line 1
The operation could not be performed because OLE DB provider "SQLNCLI" for linked server "DBServer" was unable to begin a distributed transaction.

I have set the MS DTC. It works but suddenly it stops working and throws the error.
What to do now?

Thanks.

Gunjan.
Rich96
Rich96
SSC Veteran
SSC Veteran (207 reputation)SSC Veteran (207 reputation)SSC Veteran (207 reputation)SSC Veteran (207 reputation)SSC Veteran (207 reputation)SSC Veteran (207 reputation)SSC Veteran (207 reputation)SSC Veteran (207 reputation)

Group: General Forum Members
Points: 207 Visits: 236
deepika.sharma-632099 (2/17/2008)
my issue got resolved by following step:
To allow the network transaction, you must enable MSDTC. To do this, follow these steps: a. Click Start, and then click Run.
b. In the Run dialog box, type dcomcnfg.exe, and then click OK.
c. In the Component Services window, expand Component Services, expand Computers, and then expand My Computer.
d. Right-click My Computer, and then click Properties.
e. In the My Computer Properties dialog box, click Security Configuration on the MSDTC tab.
f. In the Security Configuration dialog box, click to select the Network DTC Access check box.
g. To allow the distributed transaction to run on this computer from a remote computer, click to select the Allow Inbound check box.
h. To allow the distributed transaction to run on a remote computer from this computer, click to select the Allow Outbound check box.
i. Under the Transaction Manager Communication group, click to select the No Authentication Required option.
j. In the Security Configuration dialog box, click OK.
k. In the My Computer Properties dialog box, click OK.
source: http://support.microsoft.com/?kbid=873160


This resolved my issue when setting up a Subscription on a remote server.
gopi007d 69189
gopi007d 69189
Forum Newbie
Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)

Group: General Forum Members
Points: 3 Visits: 111
Thanks, I resolved my issue
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search