Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Report Manager DSN cannot connect to database. Help!


Report Manager DSN cannot connect to database. Help!

Author
Message
Needy Info-318558
Needy Info-318558
SSC Veteran
SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)

Group: General Forum Members
Points: 236 Visits: 98
I am trying to connect to an INFORMIX database through ODBC. I
am using the "INFORMIX-CLI 2.5 (32bit)" driver and have set up a odbc
system DSN on my computer. In report designer VS2005 the DSN works great, when
I create a datasource in Report Manager 2005 using the DSN and upload
the report I get an error that it cannot connect to the datasource. DO
I NEED an updated Informix driver?? WHY does the driver work in design
but not deployed on the server?? Everything is installed on one
computer XP, SQL2005, VS2005, DSN and Reporting Site.
srmc
srmc
Grasshopper
Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)

Group: General Forum Members
Points: 18 Visits: 15

Informix is sometimes a bear to work with but with a little troubleshooting, it can work.

Did you also setup the Informix client software and configure the ODBC on the server where reporting services is deployed. You also need to make sure your setnet32 is configured correctly on the server. The Informix client does come with a testing application to allow you to test the connection.





Needy Info-318558
Needy Info-318558
SSC Veteran
SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)

Group: General Forum Members
Points: 236 Visits: 98
Thank you for the reply, It seems like if I mention Informix everyone thinks its the devil. Here is the deal though, I have everything set up on one computer. I have SQL2005, Reporting Services 2005, Visual Studio 2005 all running on XP sp2. I have IIS 6.0 and the reporting site on the same computer. This is of course a dev system. When I am in VS2005 developing I can set a dsn using the informix odbc and I get connection to the informix database through the odbc. Then, I deploy the report to the report server (the same computer) and create a dsn using the same odbc connection. I get the reporting services error that it cannot connect to the database. So I am using the same odbc when developing and deploying but I only get connection when developing. I hope someone can explain this, I have been to many groups and no one has been able to provide a solution for a month.
Phil.Nicholas
Phil.Nicholas
SSC-Enthusiastic
SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)

Group: General Forum Members
Points: 121 Visits: 10
Could try some third party odbc drivers?


Phil Nicholas
srmc
srmc
Grasshopper
Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)Grasshopper (18 reputation)

Group: General Forum Members
Points: 18 Visits: 15

Do you have any specific error messages? Generally a datasource issue is either configuration setting or a permission problem.





Needy Info-318558
Needy Info-318558
SSC Veteran
SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)SSC Veteran (236 reputation)

Group: General Forum Members
Points: 236 Visits: 98
The error message is "
  • An error has occurred during report processing.
    • Cannot create a connection to data source 'dsJusticeData'.
      • For more information about this error navigate to the report server on the local server machine, or enable remote errors "
      • The frustrating part about this is that I have EVERYTHING running on the same computer. SQL2005, ReportManager2005, VS2005, IIS and the ODBC is on the same computer. When I am designing the report in VS2005 I create a data source that uses the Informix ODBC and it connects and works fine. When I deploy the report to Report Manager (same computer) and set up a data source to the same ODBC connection I get the error. So in summary the data source using the Informix ODBC works when I am designing the report but does not work when the report is uploaded to Report Manager and uses the same Informix ODBC (all on the same computer).

Phil.Nicholas
Phil.Nicholas
SSC-Enthusiastic
SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)SSC-Enthusiastic (121 reputation)

Group: General Forum Members
Points: 121 Visits: 10
Could try embedding the username and password into the connection string? Another thing to try might be the SQLXML web service.


Phil Nicholas
ulf.ekberg
ulf.ekberg
Forum Newbie
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)

Group: General Forum Members
Points: 2 Visits: 7
Did you ever find a solution to your problems?
regards Uffe
chandan_jha18
chandan_jha18
Mr or Mrs. 500
Mr or Mrs. 500 (513 reputation)Mr or Mrs. 500 (513 reputation)Mr or Mrs. 500 (513 reputation)Mr or Mrs. 500 (513 reputation)Mr or Mrs. 500 (513 reputation)Mr or Mrs. 500 (513 reputation)Mr or Mrs. 500 (513 reputation)Mr or Mrs. 500 (513 reputation)

Group: General Forum Members
Points: 513 Visits: 2133
ulf.ekberg (12/5/2012)
Did you ever find a solution to your problems?
regards Uffe


This thread looks quite old. Can you open a new question and post it here. That way it will be a lot easier to draw attention of volunteers.

Regards
Chandan
ulf.ekberg
ulf.ekberg
Forum Newbie
Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)Forum Newbie (2 reputation)

Group: General Forum Members
Points: 2 Visits: 7
Thanks,
Yes that would be a good idea but recently got
our problem solved, no further needs.

regards U
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search