SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SQLServerAgent : Error 1331


SQLServerAgent : Error 1331

Author
Message
bridgt01
bridgt01
Mr or Mrs. 500
Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)

Group: General Forum Members
Points: 549 Visits: 983
SQLServeragent was working yesterday but not today since our application guy got ahold of the machine. It's a standalone on SQL Server 2000/Win2KServer. Getting the following errors: [298] SQLServer Error: 1331, Cannot generate SSPI context [SQLSTATE HY000] and also [000] Unable to connect to server '(local)'; SQLServerAgent cannot start
The service is configured to logon to the local system account. NT Authority\System has sysadmin access within SQL Server. Anyone have any ideas?



larryd
larryd
Say Hey Kid
Say Hey Kid (703 reputation)Say Hey Kid (703 reputation)Say Hey Kid (703 reputation)Say Hey Kid (703 reputation)Say Hey Kid (703 reputation)Say Hey Kid (703 reputation)Say Hey Kid (703 reputation)Say Hey Kid (703 reputation)

Group: General Forum Members
Points: 703 Visits: 30
There is a good faq on this site:
http://www.sqlservercentral.com/columnists/cmiller/cannotgeneratesspicontext.asp



bridgt01
bridgt01
Mr or Mrs. 500
Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)Mr or Mrs. 500 (549 reputation)

Group: General Forum Members
Points: 549 Visits: 983
Thanks...there are some issues with AD and replication. We're going to remove AD for other reasons. I was able to get SQLServerAgent to start anyhow by using a SQL Server id rather than the local system account. If the application still doesn't work after removing AD we may have to do a complete reinstall which should completely wipe out the errors I saw.



Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search