Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Reporting services 2012 Report Manager menu url not using HTTPS


Reporting services 2012 Report Manager menu url not using HTTPS

Author
Message
chris.fordham
chris.fordham
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 42
I have recently set up a new instance of SQL Server Reporting Services 2012. ( I would have posted this in Reporting Services 2012 Administration but i did not see that) I have it running and am in the testing phase of the deploy. I have set it up to use SSL and basic Authentication. This all works. The report writer has been able to deploy reports and start testing. In this testing we discovered that the menu on the left of the report manager in the data sources or reports management window will not use https. So let me explain it more.

If you browse to a report or data source in Report Manager then highlight and click on the down arrow and choose "Manage" you will get a page with the report's or data sources' properties. It will also have a menu on the left with items like "Subscriptions", "Dependent items", and "Security". If I click on one of these items I get a 404 page error. I can then go to the url and simply put a 's' in the http so it read https and it will work.

Due to security requirements I have had to block all port 80 traffic, if I open port 80 it will work. It only works as http with port 80 open. The menu url never defaults to htts.

I have set the root url to have an https at the front. This made no change.

I tried setting the ReportServerUrl in the c:\Program Files\Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\ReportServer\rsreportserver.config file. I set it to include the https at the front as such https://DNSentry.com/reports. Yes I changed the url so the Reports is the Report Manager. This broke the entire Report Manager. It would give me an error of:

The attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version.


I have also tried to force report portal to use https by setting the secureconnectionlevel in \c:\Program Files\Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\ReportServer\rsreportserver.config to 2, then to 1 and it gave me an error both times.

The underlying connection was closed: An unexpected error occurred on a send.


If anyone knows how to force Reporting services to use https for all urls or if I am doing something wrong please let me know.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search