Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SQL 2000 to PostgreSQL 9.3 Replication of Large Number of Tables


SQL 2000 to PostgreSQL 9.3 Replication of Large Number of Tables

Author
Message
jjkido
jjkido
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 1
Hello
I am setting up a replication from a database on MS SQL 2000 that has 200+ tables to a database on PostgreSQL 9.3.

The replication works when I try replicating tables one at the time.

When replicating multiple tables though, sometimes it works
Sometimes it doesn't.

When it doesn't Work, the replication Log in MS SQL will have the following error:

Bulk copying data into table 'Tablex'
OLE DB Subscriber 'PG1': SELECT * FROM "Tablex" WHERE 0 = 1
[2/4/2014 12:18:42 PM]SQL01.distribution: {call sp_MSadd_distribution_history(71, 3, ?, ?, 0, 0, 0.00, 0x00, 1, ?, 0, 0x01, 0x00)}
Agent message code 21044. The number of columns in the bcp file does not match that of the destination table.
[2/4/2014 12:18:42 PM]SQL01.distribution: {call sp_MSadd_distribution_history(71, 6, ?, ?, 0, 0, 0.00, 0x01, 1, ?, 54, 0x01, 0x01)}
Adding alert to msdb..sysreplicationalerts: ErrorId = 39,
Transaction Seqno = 000007e3000005c9014e00000007, Command ID = 54
Message: Replication-Replication Distribution Subsystem: agent SQL01-sqldb-e-publication1-PG1-71 failed. The number of columns in the bcp file does not match that of the destination table.
[2/4/2014 12:18:42 PM]STAGE-SQL01.distribution: {call sp_MSadd_repl_alert(3, 71, 39, 14151, ?, 54, N'SQL01', N'sqldb1', N'PG1SQL56', N'pgdb1', ?)}
ErrorId = 39, SourceTypeId = 1
ErrorCode = ''
ErrorText = 'SELECT * FROM "Tablex" WHERE 0 = 1'
[2/4/2014 12:18:42 PM]SQL01.distribution: {call sp_MSadd_repl_error(39, 0, 1, ?, N'', ?)}




the funny thing is that when I set up a replication with only the failing table, it works and another table becomes problematic.
I have one set with 18 table that works perfectly.
Another table with 15 is failing.
The Ideal would be to replicate All the tables in one set but this option is failing to.
Did anybody ever run into something similar.
Your help will be highly appreciated.

Thank You,
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search