SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Distributor does his work but its always stopping


Distributor does his work but its always stopping

Author
Message
kudz
kudz
Valued Member
Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)

Group: General Forum Members
Points: 50 Visits: 458
Hi guys,

I have a transactional replication between two servers running with SQL Server 2008R2 and the distributor apparently is doing his work perfectly.
What i can't understand is why am i receiving alerts each 20minutes +- with this information

"The SQL Server performance counter 'Running' (instance 'Distribution') of object 'SQLServer:Replication Agents' now equals the threshold of 0.00."
COMMENT: AlertSQLQG001- Replication has an issue. Please check whether the distribution job is running.

JOB RUN: (None)


I already took a look on the Replication Monitor and the Job says "Running"
Has anyone had this problem before? What can i do? I tried to search online for more info about this one, but without success Sad

Thanks
Markus
Markus
SSCrazy
SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)SSCrazy (3K reputation)

Group: General Forum Members
Points: 2993 Visits: 3768
When you say it is doing all of its work but always stopping... what do you mean by always stopping?



kudz
kudz
Valued Member
Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)Valued Member (50 reputation)

Group: General Forum Members
Points: 50 Visits: 458
Hi there,

Thank you for your reply.
Well .. i don't have any undistributed command , so it seems he is doing his work Smile

I have an alert set up to tell me when the threshold of the running parameter is equal 0( that means it stopped) and i'm constantly receiving those alerts.
If I take a look into the Job Activity Monitor i dont have any indication that the job stopped, but i keep receiving the alerts from the server...

Thanks,
Tiago
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search