SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


File missing


File missing

Author
Message
SQL_Surfer
SQL_Surfer
SSCommitted
SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)

Group: General Forum Members
Points: 1678 Visits: 1098
I have a BCP command that generates files from several views. It generates about 80 files and takes about 15 mins to complete. After the files generation step is complete, I zip the files using 7za.exe. But I am running into issues of one file missing in the zip when the customer gets it. It doesn't happen every day. Just once in a while.
Any idea what could have happened during the BCP process? Anything I can do to prevent it from happening?
HanShi
HanShi
SSCrazy Eights
SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)

Group: General Forum Members
Points: 8706 Visits: 3718
From your description it is very hard to tell what the problem could be.
I suspect one of the queries within the BCP process occasionally won't return data (no rows present or maybe a non-desruptive error?). If possible build a logging mechanism inside or around the BCP process that records the rowcount of each seperate step and the creation of the file(s).

** Don't mistake the ‘stupidity of the crowd’ for the ‘wisdom of the group’! **
SQL_Surfer
SQL_Surfer
SSCommitted
SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)SSCommitted (1.7K reputation)

Group: General Forum Members
Points: 1678 Visits: 1098
with BCP logging, the following error message came out. Anything I could check?

SQLState = 08001, NativeError = 0
Error = [Microsoft][SQL Native Client]Unable to complete login process due to delay in opening server connection
HanShi
HanShi
SSCrazy Eights
SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)SSCrazy Eights (8.7K reputation)

Group: General Forum Members
Points: 8706 Visits: 3718
This error looks like the server is very busy and is under a lot of stress at that moment. Therefor it doesn't have the resources available to handle the login.
Setup a monitoring (perfmon) to see how the resources (CPU, memory, etc) are used.

** Don't mistake the ‘stupidity of the crowd’ for the ‘wisdom of the group’! **
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search