SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SSRS report previewing error


SSRS report previewing error

Author
Message
VSSGeorge
VSSGeorge
SSCrazy
SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)

Group: General Forum Members
Points: 2161 Visits: 1582
Can you help figure out for the following error messages while previewing my SSRS report. What is to be done.?

[rsParameterReference] The Value expression for the query parameter ‘@Studycode’ refers to a non-existing report parameter ‘studycode’. Letters in the names of parameters must use the correct case.
[rsInvalidReportParameterDependency] The report parameter ‘AuditCode’ has a DefaultValue or a ValidValue that depends on the report parameter “studycode”. Forward dependencies are not valid.
Failed to build item 'QAStatement.rdl'.


Thanks in advance.
kevin.minteer@gmail.com
kevin.minteer@gmail.com
Valued Member
Valued Member (66 reputation)Valued Member (66 reputation)Valued Member (66 reputation)Valued Member (66 reputation)Valued Member (66 reputation)Valued Member (66 reputation)Valued Member (66 reputation)Valued Member (66 reputation)

Group: General Forum Members
Points: 66 Visits: 368
It just means you've got mismatched capitalization for your @Studycode parameter somewhere, i.e. Studycode in one place and studycode in another. I find it's easier to just open the rdl file in a text editor and do a quick find and replace to catch any case differences.
VSSGeorge
VSSGeorge
SSCrazy
SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)

Group: General Forum Members
Points: 2161 Visits: 1582
Still I cannot fix the bug. Please explain more on this, how to fix it.
VSSGeorge
VSSGeorge
SSCrazy
SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)SSCrazy (2.2K reputation)

Group: General Forum Members
Points: 2161 Visits: 1582
Thanks for the reply. I fixed it. The problem was with the study code used in the other report parameter query for audit code.
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search