SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


proxy error in replication.


proxy error in replication.

Author
Message
Bryansky
Bryansky
SSC Eights!
SSC Eights! (872 reputation)SSC Eights! (872 reputation)SSC Eights! (872 reputation)SSC Eights! (872 reputation)SSC Eights! (872 reputation)SSC Eights! (872 reputation)SSC Eights! (872 reputation)SSC Eights! (872 reputation)

Group: General Forum Members
Points: 872 Visits: 438
I have this setup, server A is the distributor/Subscriber and server B is the publisher, SQL agent account is different in each server and they are domain accounts. Each server has an application ID, a domain account as well, say user A for server A and User B for Server B. User A and User B are both member of Admin group of both server and both are sysadmin in SQL instances in both servers. I setup a replication using the procedure by the vendor.(they have the tool to do the setup for replication for their application. just input informations and let the tool do it(in other words, a wizard. ;-)) I used User B as log reader agent(that's the only account/ID required by the tool aside from the repldata folder of subscriber and the server names). The tool said the replication is setup properly but there's error in the replication.

Date 7/05/2013 12:18:29 PM
Log Job History (<<jobname>>Wink

Step ID 2
Server <<ServerA>>
Job Name <<jobname>>
Step Name Run agent.
Duration 00:00:00
Sql Severity 0
Sql Message ID 0
Operator Emailed
Operator Net sent
Operator Paged
Retries Attempted 27

Message
Unable to start execution of step 2 (reason: Error authenticating proxy <<UserB>>, system error: Logon failure: user not allowed to log on to this computer.)

What I did was to change the credentials of the proxy(in the subscriber) to use User A instead of User B and the replication worked. I have no idea how the vendor tool setup the replication but I am guessing that the log reader agent which the one I inputted as User B are the one used by the tool to set as proxy account. but the thing is, both users are admin and sysadmin on both boxes, i wonder why i got this error. when I tried to connect via RDC using those user A to server B, i've got the error saying not allowed to use the computer. same goes with User B connecting to server A. could this be an issue? but they able to connect to the instances.

both SQLs are Enterprise, build 11.0.2325

can someone shed some light?:-)

:-)Cool
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search