SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Special characters in SSIS


Special characters in SSIS

Author
Message
GRussell31
GRussell31
SSC-Addicted
SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)

Group: General Forum Members
Points: 480 Visits: 156
Hi,

I have an issue with the loading of our data warehouse to do with special characters.

The source seems to replacing the characters with a % symbol, and I'm struggling to resolve it without changing the underlying table type from VarChar to NVarchar (which I really don't want to do).

The source database is on the same server as the warehouse but the collations are different.
The source database has a sort order of 850
The destination database is a sort order of 1252

Source and destination columns are both Varchar(50).

I can perform a simple SQL Update on each database and the characters are accepted.

If I perform a Preview on the OLE DB Source it shows the fields correctly, but when I run it (and put a data viewer on it) I can see the special characters are lost.

I've been playing with the DefaultCodePage and AlwaysUseDefaultCodePage on the Source connection with no joy.

Am I looking in the correct place?

Thanks,

Graham
GRussell31
GRussell31
SSC-Addicted
SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)SSC-Addicted (480 reputation)

Group: General Forum Members
Points: 480 Visits: 156
FYI - I have resolved this myself.

I think I was getting confused over the "AlwaysUseDefaultCodePage" property of the DataSource, I thought it was behaving in the opposite way.

Setting AlwaysUseDefaultCodePage to True means that it will use the Code Page specified in the DefaultCodePage property.

I thought it would use the SQL Server default code page.

SO in my case, I set this value to True and set the value of the DefaultCodePage to be 50.

I then checked that the advanced properties were using the correct code page for the Input, Output and Error Properties.
Then of course I had to delete and recreate all of the Unions but it now all seems to work.

Hoe that helps someone else!
Smile

Graham
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search