Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


SSIS error: version number in the package is not valid


SSIS error: version number in the package is not valid

Author
Message
J M-314995
J M-314995
SSC-Enthusiastic
SSC-Enthusiastic (103 reputation)SSC-Enthusiastic (103 reputation)SSC-Enthusiastic (103 reputation)SSC-Enthusiastic (103 reputation)SSC-Enthusiastic (103 reputation)SSC-Enthusiastic (103 reputation)SSC-Enthusiastic (103 reputation)SSC-Enthusiastic (103 reputation)

Group: General Forum Members
Points: 103 Visits: 328
I installed SSIS 2008 (SSIS, SSRS, SSAS....not the database engine) on a server that already had SQL Server 2005 installed that also had SSIS/SSRS.

I used BIDS 2008 to create an SSIS package, opened up SSMS 2008 which looks at the 2005 server engine to add/schedule a Job in the Agent to launch the SSIS 2008 package. I'm guessing this won't work because it's a SQL Server 2005 instance? Or is there a way to force the SQL Server Agent job use the C:\Program Files\Microsoft SQL Server\100\DTS\Binn\DTExec.exe instead of the one here...C:\Program Files\Microsoft SQL Server\90\DTS\Binn\DTExec.exe ???

The error I'm getting when I run the package is...

Execute Package Utility Version 9.00.5000.00 for 32-bit Copyright (C) Microsoft Corp 1984-2005. All rights reserved. Started: 8:55:33 AM Error: 2013-02-22 08:55:34.03 Code: 0xC001700A Source: Description: The version number in the package is not valid. The version number cannot be greater than current version number. End Error Error: 2013-02-22 08:55:34.03 Code: 0xC0016020 Source: Description: Package migration from version 3 to version 2 failed with error 0xC001700A "The version number in the package is not valid. The version number cannot be greater than current version number.". End Error Error: 2013-02-22 08:55:34.03 Code: 0xC0010018 Source: Description: Error loading value "<DTSTongueroperty xmlnsBigGrinTS="www.microsoft.com/SqlServer/Dts" DTS:Name="PackageFormatVersion">3</DTSTongueroperty>" from node "DTSTongueroperty". End Error Could not load package "E:\2008\logixhealth\logix.dtsx" because of error 0xC0. The step failed.
Adam Angelini
Adam Angelini
Ten Centuries
Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)Ten Centuries (1.2K reputation)

Group: General Forum Members
Points: 1204 Visits: 1177
Edit the job step and choose operating system (cmdExec) instead of SQL Server Integration Services Package. Then set your command line to something like this:

C:\Program Files\Microsoft SQL Server\100\DTS\Binn\DTExec.exe /F "c:\packagepath\packagename.dtsx"

Your package must be saved in the filesystem in order to do this.
dan-572483
dan-572483
SSChasing Mays
SSChasing Mays (643 reputation)SSChasing Mays (643 reputation)SSChasing Mays (643 reputation)SSChasing Mays (643 reputation)SSChasing Mays (643 reputation)SSChasing Mays (643 reputation)SSChasing Mays (643 reputation)SSChasing Mays (643 reputation)

Group: General Forum Members
Points: 643 Visits: 1958
Yes, this is old, but here's an answer for anyone finding this thread who is in the situation I was in...

I got this error stating it could not upgrade from version 8 to version 6. But I know for a fact I had edited the package in the SQL2012 Version of SQL Data Tools, I uploaded it to a SQL2012 SSIS instance, it ran successfully from a SQL2012 test SSIS Server I uploaded it to a few weeks ago, and when I open the DTSX file in notepad is clearly said

<DTSTongueroperty
DTS:Name="PackageFormatVersion">6</DTSTongueroperty>



THE PROBLEM:

I installed SSMS 2014 last week, which I used to upload the dtsx file to SSISDB. Apparently, SSMS upgrades lower versions of dtsx files, or at least changes the PackageFormatVersion attribute.

THE SOLUTION:

Upload the dtsx file using the version of SSMS that matches the SSIS instance. When installing newer versions of SSMS, keep the old one on your workstation for tasks where SSMS is not backward compatible.
yasser.najah 55931
yasser.najah 55931
Forum Newbie
Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)Forum Newbie (3 reputation)

Group: General Forum Members
Points: 3 Visits: 19
Hi,

I've used this as a solution and it worked.

** When you are trying to create the SSIS package in VS 2015, make sure before you create the package to do the following:

1) On the Prject Menu click on Properties (last option down the menu)
2) Under Configuration Properties, click TargetServerVersion then on the drop down menu select SQL Server 2012
3) Click Yes on the next message Screen
4) Redeploy the package
5) direct your schedule job to the new package
6) Error message won't show again and the job will complete as expected.

Thank you.;-)

Yaz
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search