SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Modify Package Issue


Modify Package Issue

Author
Message
JimS-Indy
JimS-Indy
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1061 Visits: 444
I'm trying to modify a daily backup package I built awhile back, but when I right-click on it and click "modify", I get a message that says "Agent XPs component is turned off".

I went to the SQL Server 2005 Surface Area configurator, and turned on "XP_clamshell", which I assume is the issue. It errored out with a message about "AWE". I don't understand. Can anyone help?

I should point out I'm running this instance of SS2k5 on MS Server 2008 (64bit)

Jim
Meet George Jetson
Meet George Jetson
Hall of Fame
Hall of Fame (3.9K reputation)Hall of Fame (3.9K reputation)Hall of Fame (3.9K reputation)Hall of Fame (3.9K reputation)Hall of Fame (3.9K reputation)Hall of Fame (3.9K reputation)Hall of Fame (3.9K reputation)Hall of Fame (3.9K reputation)

Group: General Forum Members
Points: 3935 Visits: 1398
XP_CMDSHELL allows you to run OS commands via T-SQL

What you wanted to do was either

sp_configure 'show advanced options', 1;
GO
RECONFIGURE;
GO
sp_configure 'Agent XPs', 1;
GO
RECONFIGURE
GO

OR since you are familiar with the Surface Area Configuration tool within SQL | Click on SQL Server Agent | change Startup to Automatic | click Start

Chris Powell

George: You're kidding.
Elroy: Nope.
George: Then lie to me and say you're kidding.
JimS-Indy
JimS-Indy
Ten Centuries
Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)Ten Centuries (1.1K reputation)

Group: General Forum Members
Points: 1061 Visits: 444
When I ran your T-SQL, I got a message set I've seen before:


Configuration option 'show advanced options' changed from 0 to 1. Run the RECONFIGURE statement to install.
Msg 5845, Level 16, State 1, Line 1
Address Windowing Extensions (AWE) requires the 'lock pages in memory' privilege which is not currently present in the access token of the process.
Configuration option 'Agent XPs' changed from 0 to 1. Run the RECONFIGURE statement to install.
Msg 5845, Level 16, State 1, Line 1
Address Windowing Extensions (AWE) requires the 'lock pages in memory' privilege which is not currently present in the access token of the process.


Jim
mhouse
mhouse
Forum Newbie
Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)Forum Newbie (1 reputation)

Group: General Forum Members
Points: 1 Visits: 213
Hi Jim

Mr. Jetson's script should work to solve the problems with the Agent XP's being disabled. The problem here is that you have 2 problems.

When you enable Agent XPs, you're essentially changing the "Configured Value" of "Agent XP's" from 0 to 1. When you run RECONFIGURE, you're asking SQL to make all the "Configured Values" on your server to their "Run Values" where possible. This RECONFIGURE applies to all configured values.

Your second problem here is that you have AWE enabled on this server. If you check sp_configure you'll see that the "Configured Value" is 1, but the "Run Value" is 0. So when you run RECONFIGURE, SQL tries to enable the Agent XPs and also enable AWE. Your AWE isn't working because your SQL Server service account doesn't have the OS-level "Lock Pages In Memory" privilege.

-- Confirm that AWE configured_value = 1, but run_value = 0. Assuming confirmation, proceed with below steps.
EXEC sp_configure 'awe enabled'

-- If so, temporarily turn off AWE so that its error doesn't block other configurations
EXEC sp_configure 'awe enabled', 0

-- RECONFIGURE will now not be "blocked" by the erroring AWE setting
RECONFIGURE

-- Reset the AWE value to its original value. Note that AWE isn't fixed, you're just putting things back where they were.
EXEC sp_configure 'awe enabled', 1

-- Go fix the AWE problem
-- http://technet.microsoft.com/en-us/library/ms190673(v=sql.90).aspx
-- http://technet.microsoft.com/en-us/library/ms190730(v=sql.90).aspx



Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search