Click here to monitor SSC
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Communication link failure - Shared Memory Provider: No process is on the other end of the pipe


Communication link failure - Shared Memory Provider: No process is on the other end of the pipe

Author
Message
YearMonthDay
YearMonthDay
Forum Newbie
Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)

Group: General Forum Members
Points: 7 Visits: 148
Dear All,

I having a SSIS package to process the cube (SSAS 2008) in daily basic. This morming I check the SQL Agent and noticed the SSIS package was failed and the error (error message from ERRORLOG file) as below:-

Message: OLE DB error: OLE DB or ODBC error: Protocol error in TDS stream; HY000; Communication link failure; 08S01; Shared Memory Provider: No process is on the other end of the pipe.
; 08S01; Communication link failure; 08S01; Shared Memory Provider: No process is on the other end of the pipe.
; 08S01. (Source: \\?\F:\Program Files\Microsoft SQL Server\MSAS10.MSSQLSERVER\OLAP\Log\msmdsrv.log, Type: 3, Category: 289, Event ID: 0xC1210003)

I have manual re-run the SSIS package and it was successfully executed without error. But my client would like me to explain why the SSIS package was failed.

Could anyone can help me on this? What are the reasons can cause this error?

Thanks
YearMonthDay
YearMonthDay
Forum Newbie
Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)Forum Newbie (7 reputation)

Group: General Forum Members
Points: 7 Visits: 148
Hi All,

I was wondering anybody know the root cause?

Thanks
jon_curriculum
jon_curriculum
Valued Member
Valued Member (53 reputation)Valued Member (53 reputation)Valued Member (53 reputation)Valued Member (53 reputation)Valued Member (53 reputation)Valued Member (53 reputation)Valued Member (53 reputation)Valued Member (53 reputation)

Group: General Forum Members
Points: 53 Visits: 108
Hello, I'm facing the same problem. When I run manually it works perfectly, but not when I use a job that calls my package.
Information detected about error :
PackageName --> XXXXXXXXXXX
System Error Code: -1056571392
System Error Description:OLE DB error: OLE DB or ODBC error: Protocol error in TDS stream; HY000; Communication link failure; 08S01; TCP Provider: An existing connection was forcibly closed by the remote host.
; 08S01; Communication link failure; 08S01; TCP Provider: An existing connection was forcibly closed by the remote host.
; 08S01; Communication link failure; 08S01; TCP Provider: An existing connection was forcibly closed by the remote host.
; 08S01.
System Configurations failed:
---------------------------------------------
I'm going to reproduce the steps I'm performing:
1- I'm connected to a remote terminal server from where I can connect to my SSIS Server through SSMS.
2- I've got a job pointing to an SSIS package which is deployed in the same server.
3- Running mannually the job, it fails after a while with the previous error.

I have run again the job and it has failed with the following error:

Information detected about error :
PackageName --> XXXXXXXXXX
System Error Code: -1056571392
System Error Description:OLE DB error: OLE DB or ODBC error: Operation canceled; HY008.
System Configurations failed:

Information detected about error :
PackageName --> XXXXXXXXXX
System Error Code: -1054932980
System Error Description:Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Dim XXX', Name of 'Dim XXX' was being processed.
System Configurations failed:

Information detected about error :
PackageName --> XXXXXXXXXX
System Error Code: -1056571392
System Error Description:OLE DB error: OLE DB or ODBC error: The request failed to run because the batch is aborted, this can be caused by abort signal sent from client, or another request is running in the same session, which makes the session busy.; 42000.
System Configurations failed:
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum

































































































































































SQLServerCentral


Search