SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Cannot run cataloged SSIS package from stored procedure within ASP.Net.


Cannot run cataloged SSIS package from stored procedure within ASP.Net.

Author
Message
Karen Grube
Karen Grube
SSChasing Mays
SSChasing Mays (602 reputation)SSChasing Mays (602 reputation)SSChasing Mays (602 reputation)SSChasing Mays (602 reputation)SSChasing Mays (602 reputation)SSChasing Mays (602 reputation)SSChasing Mays (602 reputation)SSChasing Mays (602 reputation)

Group: General Forum Members
Points: 602 Visits: 413
Remove alert|Edit|Delete|Change typeQuestionYou cannot vote on your own post
HI!
I'm running the most recent versions of SQL Server, Integration Services (SSDT) and Visual Studio on a Windows 2012 R2 server

Using an Integration Services Project, I created an SSIS package. It runs perfectly.I deployed that package to the SSIS Catalog. I created a stored procedure that runs that SSIS package. It runs perfectly

However,I need to execute the stored procedure from an ASP.net web page, and when I do, I get the following error:
"The server principal \"WORKGROUP\\MYSERVERNAME$\" is not able to access the database \"SSISDB\" under the current security context."

The account I'm signed in as is in the Windows Administrator Group. That account is a sysadmin on the database server. I have added that account to the "ssis_admin" role in SSISDB.

The Server has four databases, including SSISDB. The stored procedure runs from one of the other databases, we'll call it "ITDatabase"

The stored procedure actually starts when it runs from the VS Debugger. The initial steps of that stored procedure execute, but it stops when it tries to execute the SSIS package from the catalog.

In IIS 6.2 , when I go to the Application Pools and look at the Default App Pool and look at the "Advanced" settings" I can see that Default App Pool is running under Local System. I experimented and changed the Process Model Identity to the login I use to sign on to the server. When I did that then ran the ASP.Net page in the Visual Studio debugger, the process completed without error.

Of course, I changed the App Pool Process Model Identity that back to Local Service. I can't have the app pool running under my login.

I hope someone has some suggestions. I'm not sure how to configure security so this package will run from ASP.Net

Thanks!
Subramaniam Chandrasekar
Subramaniam Chandrasekar
Hall of Fame
Hall of Fame (3.4K reputation)Hall of Fame (3.4K reputation)Hall of Fame (3.4K reputation)Hall of Fame (3.4K reputation)Hall of Fame (3.4K reputation)Hall of Fame (3.4K reputation)Hall of Fame (3.4K reputation)Hall of Fame (3.4K reputation)

Group: General Forum Members
Points: 3436 Visits: 531
Karen Grube - Tuesday, February 13, 2018 9:58 PM
Remove alert|Edit|Delete|Change typeQuestionYou cannot vote on your own post
HI!
I'm running the most recent versions of SQL Server, Integration Services (SSDT) and Visual Studio on a Windows 2012 R2 server

Using an Integration Services Project, I created an SSIS package. It runs perfectly.I deployed that package to the SSIS Catalog. I created a stored procedure that runs that SSIS package. It runs perfectly

However,I need to execute the stored procedure from an ASP.net web page, and when I do, I get the following error:
"The server principal \"WORKGROUP\\MYSERVERNAME$\" is not able to access the database \"SSISDB\" under the current security context."

The account I'm signed in as is in the Windows Administrator Group. That account is a sysadmin on the database server. I have added that account to the "ssis_admin" role in SSISDB.

The Server has four databases, including SSISDB. The stored procedure runs from one of the other databases, we'll call it "ITDatabase"

The stored procedure actually starts when it runs from the VS Debugger. The initial steps of that stored procedure execute, but it stops when it tries to execute the SSIS package from the catalog.

In IIS 6.2 , when I go to the Application Pools and look at the Default App Pool and look at the "Advanced" settings" I can see that Default App Pool is running under Local System. I experimented and changed the Process Model Identity to the login I use to sign on to the server. When I did that then ran the ASP.Net page in the Visual Studio debugger, the process completed without error.

Of course, I changed the App Pool Process Model Identity that back to Local Service. I can't have the app pool running under my login.

I hope someone has some suggestions. I'm not sure how to configure security so this package will run from ASP.Net

Thanks!

I've got an MSDN article for you !

https://social.msdn.microsoft.com/Forums/sqlserver/en-US/29218f47-bd50-4381-8744-637ad15ebbc9/execute-ssis-package-from-aspnet-with-parameter-datatype-varcharmax?forum=sqlintegrationservices

It seems similar issue for the poster too !

Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search