SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


sql server 2008 r2 - TLS 1.2 support + Meltdown/Spectre patch


sql server 2008 r2 - TLS 1.2 support + Meltdown/Spectre patch

Author
Message
miapjp
miapjp
Old Hand
Old Hand (378 reputation)Old Hand (378 reputation)Old Hand (378 reputation)Old Hand (378 reputation)Old Hand (378 reputation)Old Hand (378 reputation)Old Hand (378 reputation)Old Hand (378 reputation)

Group: General Forum Members
Points: 378 Visits: 242
Hi,

Please bear with me, I'm an accidental DBA, I'd prefer creating report queries all day long, but.... Our main software vendor put out a notice saying a third party vendor is requiring they use TLS 1.2, and pointed us towards the SQL Patch for that. This vendor (who we may start using in the future) transmits data from our database to our/their customers (HL7). The software vendor's software would be compatible with it after a certain build. I tried looking that up, and am confused about exactly WHERE the TLS 1.2 would be used - web servers, windows server, sql server...it's all confusing to me because it's used all over the place. And I think it has to be enabled - on the server? first.

The MSSQL page for the TLS 1.2 patch says for 2008R2 the first build to support TLS 1.2 is 10.50.6542.0. I think the TLS patch makes it that build? So I was going to try it on the test system (which isn't apples to apples, but all I got). That was already at SP3. I put on the security patches from MS15-058 (KB3045316 and KB3045314). Then I put on the Meltdown/Spectre patch and brought me up to 10.50.6560. I then tried to put on the TLS 1.2 patch, but it wouldn't let me - said there was no product it could be applied to (or something like that).

So my question is this: the MSSQL TLS 1.2 page says the first build that supports TLS 1.2 is 10.50.6542.0. Now that I'm on a build higher than that, is the TLS 1.2 support installed? It was a hotfix/patch/whatever, and not a CU, so I'm not sure if the TLS 1.2 support is included in the Meltdown/Spectre patch. I should have done the two security patches, then the TLS, the the Meltdown/Spectre. But I can skip a step if the TLS is included in Meltdown/Spectre. And I'm thinking as I write, could I have skipped the two security patches AND the TLS and just done Meltdown/Spectre - would that install those three patches along with Meltdown/Spectre?

I hope this question makes sense, I know I'm not using the right words (I don't have the best words :-))

Pat
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum








































































































































































SQLServerCentral


Search