SQL Clone
SQLServerCentral is supported by Redgate
 
Log in  ::  Register  ::  Not logged in
 
 
 


Long-running script with IE11


Long-running script with IE11

Author
Message
zouhair.ouichdani
zouhair.ouichdani
SSC-Enthusiastic
SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)

Group: General Forum Members
Points: 153 Visits: 210
Hi guys,
I am currently facing an issue with SSRS 2008 and I will like to get your support regarding this.
I have a report which can run without any problem, from report builder (prod).
However, when I run it directly from report server with IE11, It will show the following message after 2 minutes:"server is not responding due to a long-running script"
This only happen when my table have many records,in this case more than 5000 records should be displayed on the report.Once I removed this table from my report, It will run smoothly.
I have also tried to add the Page break option to "Keep together on one page if possible" but without any success.
Can you please give me any suggestions?

Thank you for your support.

Cheers,
Thom A
Thom A
SSC Guru
SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)

Group: General Forum Members
Points: 86694 Visits: 22261
The problem isn't IE11, it's that your SSRS instance is set to time out the query after 2 minutes. As your report is taking more than 2 minute to run and render, the error is presented.

You can change a report's time out settings in the processing options, when managing your report in the Web Portal. Alternatively, you can change the global default, which is would in the configuration file for Reporting Services. If I recall correctly, the node is called QueryTimeout, or DatabaseQueryTimeout. Most likely it will have a value of 120 (seconds), which is 2 minutes.

To amend the global setting you'll need to restart the SSRS service after saving the new copy of the configuration file. Personally, however, I prefer to stop it, save, and the start; just in case SSRS decides to save off the current settings when it stops (like some applications do).


Thom~
Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does :-P

Please always remember to encapsulate your code in IFCode Markup. For example [code=sql] [/code].
Click here to read Jeffs Guide on how to post SQL questions, and get swift and helpful answers from the community
zouhair.ouichdani
zouhair.ouichdani
SSC-Enthusiastic
SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)

Group: General Forum Members
Points: 153 Visits: 210
Hi Thom,
Thank you for your prompt reply.
Regarding the Report timeout it's already set to 3600 seconds.(Site Setting->General->Report Timeout) but it does not solve the problem.
I have other report which run more than 2 min but provides results.
So I don't think it's related to that or maybe I am not looking in the right timeout configuration .
Thom A
Thom A
SSC Guru
SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)

Group: General Forum Members
Points: 86694 Visits: 22261
zouhair.ouichdani - Monday, October 9, 2017 6:11 AM
Hi Thom,
Thank you for your prompt reply.
Regarding the Report timeout it's already set to 3600 seconds.(Site Setting->General->Report Timeout) but it does not solve the problem.
I have other report which run more than 2 min but provides results.
So I don't think it's related to that or maybe I am not looking in the right timeout configuration .


What is the setting on the report itself?


Thom~
Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does :-P

Please always remember to encapsulate your code in IFCode Markup. For example [code=sql] [/code].
Click here to read Jeffs Guide on how to post SQL questions, and get swift and helpful answers from the community
zouhair.ouichdani
zouhair.ouichdani
SSC-Enthusiastic
SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)

Group: General Forum Members
Points: 153 Visits: 210
From report server when I launch report builder to open the report and execute it,it works without any issue and I get results in about 2minutes.
What do you mean by report setting?
Thom A
Thom A
SSC Guru
SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)

Group: General Forum Members
Points: 86694 Visits: 22261
zouhair.ouichdani - Monday, October 9, 2017 6:33 AM
From report server when I launch report builder to open the report and execute it,it works without any issue and I get results in about 2minutes.
What do you mean by report setting?


On the report itself you can also set time out settings. What does the report's own setting state?


Thom~
Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does :-P

Please always remember to encapsulate your code in IFCode Markup. For example [code=sql] [/code].
Click here to read Jeffs Guide on how to post SQL questions, and get swift and helpful answers from the community
zouhair.ouichdani
zouhair.ouichdani
SSC-Enthusiastic
SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)

Group: General Forum Members
Points: 153 Visits: 210
From the report itself I set Report timeout on the processing option to 'Do not timeout report',I restarted Report server afterwards,but still the same issue.
Thom A
Thom A
SSC Guru
SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)

Group: General Forum Members
Points: 86694 Visits: 22261
Could you have a look at the SSRS logs, see if it's showing anything in there in regards to your report.


Thom~
Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does :-P

Please always remember to encapsulate your code in IFCode Markup. For example [code=sql] [/code].
Click here to read Jeffs Guide on how to post SQL questions, and get swift and helpful answers from the community
zouhair.ouichdani
zouhair.ouichdani
SSC-Enthusiastic
SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)SSC-Enthusiastic (153 reputation)

Group: General Forum Members
Points: 153 Visits: 210
Hi Tom,
I checked the logs and it seems that it initilaize the DatabaseQueryTimeout to 120 seconds.
So I run this script to put the time out unlimilited
EXEC sp_configure 'remote query timeout', 0 ;
GO
RECONFIGURE ;
GO

But I still have the same problem and the DatabaseQueryTimeout is still set to 120 seconds.

Thom A
Thom A
SSC Guru
SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)SSC Guru (86K reputation)

Group: General Forum Members
Points: 86694 Visits: 22261
DatabaseQueryTimeout is a setting in your SSRS config file, as I stated in my 1st reply. Sounds like that is still set to 120. Like I said before, check it and up the value if needed.



Thom~
Excuse my typos and sometimes awful grammar. My fingers work faster than my brain does :-P

Please always remember to encapsulate your code in IFCode Markup. For example [code=sql] [/code].
Click here to read Jeffs Guide on how to post SQL questions, and get swift and helpful answers from the community
Go


Permissions

You can't post new topics.
You can't post topic replies.
You can't post new polls.
You can't post replies to polls.
You can't edit your own topics.
You can't delete your own topics.
You can't edit other topics.
You can't delete other topics.
You can't edit your own posts.
You can't edit other posts.
You can't delete your own posts.
You can't delete other posts.
You can't post events.
You can't edit your own events.
You can't edit other events.
You can't delete your own events.
You can't delete other events.
You can't send private messages.
You can't send emails.
You can read topics.
You can't vote in polls.
You can't upload attachments.
You can download attachments.
You can't post HTML code.
You can't edit HTML code.
You can't post IFCode.
You can't post JavaScript.
You can post emoticons.
You can't post or upload images.

Select a forum









































































































































































SQLServerCentral


Search