Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

"Cursor operation conflict" Expand / Collapse
Author
Message
Posted Tuesday, November 4, 2008 11:02 PM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, July 14, 2014 4:48 AM
Points: 2,834, Visits: 3,950
HI

INSERT INTO [srsvr\dev].db_lines.dbo.SYNC_OBJECT_RECEIVE_IN_M(object_name,eventtype,Created_by)

SELECT TOP 2 object_name,eventtype,Created_by FROM db_lines.dbo.SYNC_OBJECT_SEND_HQ_M Order By Created_by



I m executing above remote query and its giving error
OLE DB provider "SQLNCLI" for linked server "srvr\dev" returned message "Cursor operation conflict".

Msg 7343, Level 16, State 2, Line 1

The OLE DB provider "SQLNCLI" for linked server "srvr\dev" could not INSERT INTO table "[srvr\dev].[DB_line].[dbo].[SYNC_OBJECT_RECEIVE_IN_M]".


i have seen in a forum that we need to check OFF the setting in connection of server but it didnt work ?


Please Help



-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #597106
Posted Sunday, November 9, 2008 1:03 AM


Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Tuesday, July 15, 2014 2:10 AM
Points: 1,093, Visits: 1,221
I am not sure, but I think your servers must be linked servers. First link them and then try. (May be I guess right)

Mahesh


MH-09-AM-8694
Post #599524
Posted Sunday, November 9, 2008 10:34 PM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, July 14, 2014 4:48 AM
Points: 2,834, Visits: 3,950
hi mahesh ..iys not like that i have liniked the server buyt still this error occurs..



-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #599642
Posted Sunday, November 9, 2008 11:08 PM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Thursday, March 13, 2014 5:49 AM
Points: 1,391, Visits: 608
navigate the following URL's you will get the answer:

Code:
------
Needed to Set NOCOUNT ON and change

sp_configure "user options", 512

to

sp_configure "user options", 0

URL's:
------
http://support.microsoft.com/kb/195491
http://www.sqlnewsgroups.net/group/microsoft.public.sqlserver.server/topic10693.aspx



Post #599648
Posted Monday, November 10, 2008 12:04 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Monday, July 14, 2014 4:48 AM
Points: 2,834, Visits: 3,950
thanks buddy it works !!!!!!!!!!

-------Bhuvnesh----------
I work only to learn Sql Server...though my company pays me for getting their stuff done
Post #599661
Posted Wednesday, April 30, 2014 11:49 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, June 6, 2014 4:54 PM
Points: 1, Visits: 41
Very good. This saved me. I can't figure out which config setting it changed, though.
Post #1566532
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse