Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

After Trigger Expand / Collapse
Author
Message
Posted Sunday, February 17, 2008 11:29 PM
Right there with Babe

Right there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with BabeRight there with Babe

Group: General Forum Members
Last Login: Friday, January 17, 2014 1:22 PM
Points: 727, Visits: 265
I read the contents of one particular column of the inserted table, but it is mysteriously not there. I get zero (datatype is money, Null). Immediately after the trigger fires, I SELECT from the table and the column has been inserted correctly. I'm doing similar things with other columns, and all is well there.

I've tried adding some logging into a log table to verify my observations (INSERT INTO LogTable SELECT MissingCol, GetDate() FROM inserted). I've done extensive work with triggers for years, and I'm pretty sure I'm doing all the normal things correctly.

There's really no other code to show. I'm thinking this is a SQL bug of some sort but I haven't found it yet on the MS site. Has anyone encountered such an anomaly?

Thanks
Paul


- Paul

http://paulpaivasql.blogspot.com/
Post #456792
Posted Sunday, February 17, 2008 11:53 PM


SSC-Forever

SSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-Forever

Group: General Forum Members
Last Login: Today @ 10:05 AM
Points: 42,829, Visits: 35,961
Haven't heard of this happening before.

Can you post the trigger code, the table schema and the insert statement that you tried?

What's the version of your SQL server? What SP?



Gail Shaw
Microsoft Certified Master: SQL Server 2008, MVP
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass

Post #456796
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse