Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
Log in  ::  Register  ::  Not logged in
Home       Members    Calendar    Who's On

Add to briefcase

select query does not return any resultset Expand / Collapse
Posted Sunday, July 7, 2013 12:20 AM


Group: General Forum Members
Last Login: Sunday, September 27, 2015 6:07 AM
Points: 110, Visits: 761
hi all,

i have a table with 74 rows. when i run a select statement on it, it does not return any resultset.

for the same query if i use the nolock hint , it does return the result.

i ran a profiler to see what is happening behind the scene and i see only the SQL:BatchStarting

i donot see the table being locked in the activity monitor. no error in the event viewer for SQL. only a below warning

[ warning] [vmusr:vmusr] Error in the RPC receive loop: RpcIn: Unable to send . there exist a hotfix for this error and it will be applied.but not sure if the strange behaviour is due to this any suggestions ?

also, if i run select statment against any other table it runs without any error.

dbcc checktable returns no error.
DBCC results for 'POLICY_LOCKS'.
There are 74 rows in 1 pages for object "POLICY_LOCKS".
DBCC execution completed. If DBCC printed error messages, contact your system administrator.

sql version: SQL server 2005 with SP4
Windows: Server 2003 Enterprise Editionwith SP2

Post #1470965
Posted Tuesday, July 23, 2013 1:10 PM

SSChasing Mays

SSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing MaysSSChasing Mays

Group: General Forum Members
Last Login: Yesterday @ 4:45 PM
Points: 610, Visits: 1,271
dbcc opentran
to look for any open transaction. If nothing, you can try issuing a 'checkpoint' command on the database to commit data in the systems memory.
Post #1476762
Posted Tuesday, July 30, 2013 7:15 PM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Tuesday, November 24, 2015 1:51 AM
Points: 202, Visits: 770
Maybe you get some useful information about what locks the table using sys.dm_tran_locks (
There are some other Transaction Related Dynamic Management Views and Functions that might help you:
Post #1479251
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse