Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Disabling FileStream Expand / Collapse
Author
Message
Posted Monday, August 16, 2010 2:23 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, September 4, 2014 8:46 PM
Points: 5, Visits: 90
Hello,

We have a new sharepoint 2010 farm setup and we were playing with fliestream. We decided not to use it and I disabled filestream. After restarting the sql service, the database went off-line and I got the following message:

Database '<db_name>' cannot be opened due to inaccessible files or insufficient memory or disk space. See the SQL Server errorlog for details.

I looked at the log file and saw the following:

FILESTREAM feature is disabled.
Error: 5105, Severity: 16, State: 14.
A file activation error occurred. The physical file name '<path>be incorrect. Diagnose and correct additional errors, and retry the operation.

How do I get around this issue? How do I disable filestream without making the database inaccessible?

Thanks in advance for any input.


Post #970024
Posted Monday, August 16, 2010 4:23 PM
SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Yesterday @ 2:22 PM
Points: 2,881, Visits: 3,078
Enable filestream, remove the filestream file from the database files, remove the filestream filegroup, and disable filestream again. That should solve your issue.
Post #970082
Posted Monday, August 16, 2010 9:21 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, September 4, 2014 8:46 PM
Points: 5, Visits: 90
I tried deleting the files but I got a message the files cannot be dropped because its not empty. So, I did DBCC SHRINKFILE (RBSFilestreamFile, EMPTYFILE) and I got the following error message:

Msg 5509, Level 15, State 3, Line 1
The properties SIZE, MAXSIZE, or FILEGROWTH cannot be specified for the FILESTREAM data file 'RBSFilestreamFile'.

Do I have to manually go to the share and delete the files from there and then drop the file and filegroup?
Post #970121
Posted Tuesday, August 17, 2010 12:27 PM


SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Today @ 10:23 AM
Points: 6,425, Visits: 13,821
also, you may want to post in the correct forum section in future

-----------------------------------------------------------------------------------------------------------

"Ya can't make an omelette without breaking just a few eggs"
Post #970656
Posted Wednesday, July 9, 2014 12:18 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Monday, August 18, 2014 12:09 AM
Points: 1, Visits: 57
Hi

I am also facing the same issue.
A file activation error occurred. The physical file name 'E: may be incorrect. Diagnose and correct additional errors, and retry the operation.
Error: 5105, Severity: 16, State: 14.
FILESTREAM feature is disabled.
Error: 5591, Severity: 16, State: 5.

Please let me know, how to resolve this issue.

suppoose if i enable the FILESTREAM feature and then restart the sql instance, the issue will resolved or not.
Post #1590597
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse