Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

The credentials you provided for the SQL Server Agent service are invalid Expand / Collapse
Author
Message
Posted Monday, May 3, 2010 4:50 PM


SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Sunday, August 10, 2014 4:15 AM
Points: 293, Visits: 816
Hi,
I'm receiving the following error while running through the install

[Error Message]
The credentials you provided for the SQL Server Agent service are invalid. To continue, provide a valid account and password for the SQL Server Agent service.

[Details]
Microsoft.SqlServer.Configuration.Agent.InputValidationException: The credentials you provided for the SQL Server Agent service are invalid. To continue, provide a valid account and password for the SQL Server Agent service.


I can log in as the domain account I am attempting to use as the service account.
The account is a local admin.
The account has been granted log on as service permissions in AD and Local security policies
DNS is working...
Post #915004
Posted Tuesday, May 25, 2010 6:37 AM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Monday, May 16, 2011 8:22 AM
Points: 378, Visits: 353
Hi,

I had this same problem when installing. I ended up using a different local admin account (that was not a service account) with permissions during the install, then changing to the service account in Configuration Manager after the install was complete - and it then accepted the domain service account with no problems after that!

Jinx.
Post #927403
Posted Tuesday, May 25, 2010 9:11 AM


SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Sunday, August 10, 2014 4:15 AM
Points: 293, Visits: 816
For me this was an incorrectly configured AD OU
Post #927567
Posted Monday, February 25, 2013 7:09 AM
SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Today @ 9:11 AM
Points: 265, Visits: 850
Hey - Jon, how did you verified that was problem with the object ?
Post #1423600
Posted Monday, February 25, 2013 9:55 AM


SSC Veteran

SSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC VeteranSSC Veteran

Group: General Forum Members
Last Login: Sunday, August 10, 2014 4:15 AM
Points: 293, Visits: 816
I actually didn't the systems admins / AD admins came back with an "oops sorry about that".
Post #1423675
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse