Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

How to disable intellisense in SQL 2008 permanently Expand / Collapse
Author
Message
Posted Wednesday, November 11, 2009 7:59 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Monday, May 24, 2010 12:38 AM
Points: 9, Visits: 24
HI,

I want to disable intellisense in SQL server 2008 permanently for SQL client by script.

Note : I do not want disable it by using the IDE.

Ones disabled, only the Administrator should enable it. Client should not be given option to enalbe.


Kindly give your suggestions


Regards
Jim
Post #817174
Posted Wednesday, November 11, 2009 8:02 AM


SSCoach

SSCoachSSCoachSSCoachSSCoachSSCoachSSCoachSSCoachSSCoachSSCoachSSCoachSSCoach

Group: General Forum Members
Last Login: Friday, June 27, 2014 12:43 PM
Points: 15,444, Visits: 9,596
If you deny select on the system objects to the accounts that aren't supposed to have intellisense, that should do it. It depends on the ability to select from the system schema views (sys.all_objects, sys.columns, and so on), if I'm not mistaken.

Try that, see how it goes.


- Gus "GSquared", RSVP, OODA, MAP, NMVP, FAQ, SAT, SQL, DNA, RNA, UOI, IOU, AM, PM, AD, BC, BCE, USA, UN, CF, ROFL, LOL, ETC
Property of The Thread

"Nobody knows the age of the human race, but everyone agrees it's old enough to know better." - Anon
Post #817180
Posted Monday, November 16, 2009 3:14 AM


SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: Saturday, August 30, 2014 4:20 PM
Points: 11,194, Visits: 11,142
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\100\Tools\Shell\Languages\Language Services\SQL

CodeSense = 0




Paul White
SQL Server MVP
SQLblog.com
@SQL_Kiwi
Post #819273
Posted Friday, November 27, 2009 5:32 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, November 27, 2009 5:27 AM
Points: 2, Visits: 2
It appears that in Options->Text Editors->XAML, the Intellisense section is section is unavailable (grayed out). We open documents in Full XAML View, and don't use any third party enhancements.

rapid fire controller
xbox controller mod
Post #825568
Posted Tuesday, December 1, 2009 6:05 AM


SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Tuesday, August 19, 2014 1:31 PM
Points: 416, Visits: 573
Check this article, this might help you

http://sql-articles.com/articles/dba/intellisence-sql-server-2008


Regards..Vidhya Sagar
SQL-Articles
Post #826586
Posted Monday, March 29, 2010 2:00 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Saturday, June 12, 2010 9:31 AM
Points: 12, Visits: 14
Here is the solution you are looking for you,
http://sqlserver.ro/blogs/cristians_blog/archive/2007/11/20/turning-off-intellisense-in-sql-server-2008-ctp5.aspx
Post #891638
Posted Monday, March 29, 2010 2:21 AM


SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: Saturday, August 30, 2014 4:20 PM
Points: 11,194, Visits: 11,142
battula.praveen (3/29/2010)
Here is the solution you are looking for you[/url]

I posted the same thing three posts before you.




Paul White
SQL Server MVP
SQLblog.com
@SQL_Kiwi
Post #891646
Posted Monday, March 29, 2010 2:32 AM
Grasshopper

GrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopperGrasshopper

Group: General Forum Members
Last Login: Saturday, June 12, 2010 9:31 AM
Points: 12, Visits: 14
Sorry, didn't look at your second post. That was my mistake. Please don't consider it.

thanks
Post #891652
Posted Thursday, November 29, 2012 10:23 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, May 23, 2014 2:06 AM
Points: 1, Visits: 10
From SSMS
Tools>Options>Text Editor>Transact SQL>Intellisense> Enable/Disable
Post #1391012
Posted Thursday, November 29, 2012 11:00 PM


SSChampion

SSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampionSSChampion

Group: General Forum Members
Last Login: Saturday, August 30, 2014 4:20 PM
Points: 11,194, Visits: 11,142
tony.price.uk (11/29/2012)
From SSMS
Tools>Options>Text Editor>Transact SQL>Intellisense> Enable/Disable

This works, of course, but it doesn't address the requirement in the first post.




Paul White
SQL Server MVP
SQLblog.com
@SQL_Kiwi
Post #1391018
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse