Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 123»»»

Report Manager Home Page almost blank-SSRRS2005 -Please Advise!! Expand / Collapse
Author
Message
Posted Thursday, September 3, 2009 10:30 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, August 11, 2014 2:21 PM
Points: 136, Visits: 1,240
Hi,

I installed SSRS 2005 on a Windows Server 2003 box, which runs IE7. The report manager home page comes up when i put this in the browser-http://localhost/reports$ReportServer/Pages/Folder.aspx

However it only shows me the home page with the home , mysubscriptions and help links on the upper right corner.

I do not see the tab to add/manage data sources, folders, properties etc.

I have tried the following

1] I made sure the box for -enable annoymous authentication(inetmgr->IIS-->Report server virtual directory--> properties--->directory security -was left unchecked

2] In the same tab i checked the box for Allow integrated windows authentication

3]I added the url http://localhost/reports to the list of trusted sites for IE

4] I have logged in as the local administrator of the box, using the service account as well and running IE but it still did not make any difference.

I really do not know what to do at this point , this is my first installation on a server.

Please do let me know, looking forward to your suggestions.
Post #782362
Posted Thursday, September 3, 2009 12:44 PM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Tuesday, July 29, 2014 8:19 AM
Points: 33, Visits: 23,402
JD,

Are you on a domain? Did you give yourself permissions to see the "Home" directory (ie. MACHINENAME\username)?

1. Log in as an administrator
2. Open the browser and navigate to http://localhost/reports
3. Click on Site settings
4. Click Configure site-wide security
5. Out of the box, you should see BUILTIN\Administrators as a role of System Administrator. As such, you should see the home directory in this case. When you go to the Home directory, you should see Properties tab. Click on it and then Add Role Assignment. Add your local user account and at the very least you have to give the user the "Browser" role to see this folder.

Try this and let me know the results.

I hope this helps, but either way, let me know and I will keep trying to work with you.

Good luck and take care,


Brian K. McDonald, MCDBA, MCSD


Brian K. McDonald, MCDBA, MCSD
Business Intelligence Consultant
Jacksonville, Florida
Post #782486
Posted Thursday, September 3, 2009 1:04 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, August 11, 2014 2:21 PM
Points: 136, Visits: 1,240
Hi Brian,

I do not see site settings as well , i have attached a screenshot of what i can see, maybe it might help.


  Post Attachments 
ReportManagerHome.png (75 views, 24.92 KB)
Post #782502
Posted Thursday, September 3, 2009 1:06 PM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Tuesday, July 29, 2014 8:19 AM
Points: 33, Visits: 23,402
And you are logged in as the Administrator? You could also choose to "Run as Administrator" by right clicking the IE icon.

Brian K. McDonald, MCDBA, MCSD
Business Intelligence Consultant
Jacksonville, Florida
Post #782504
Posted Thursday, September 3, 2009 1:13 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, August 11, 2014 2:21 PM
Points: 136, Visits: 1,240
I am logged in as the local admin on the box, i tried running IE as administrator but it always failed to authenticate me with any username or password i put in.

Thats why i logged out , logged back in as the local admin(and i face no problems when i do this) and loaded the report manager home page..
Post #782509
Posted Thursday, September 3, 2009 1:19 PM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Tuesday, July 29, 2014 8:19 AM
Points: 33, Visits: 23,402
Gotcha!

So you can see the home page when you log in as the local admin. When you are logged in as the admin, do you see the Properties tab? See the attached screenshot.

If you can see that and navigate to it, let me know.


Brian K. McDonald, MCDBA, MCSD
Business Intelligence Consultant
Jacksonville, Florida


  Post Attachments 
Home - Properties.JPG (44 views, 18.00 KB)
Post #782515
Posted Thursday, September 3, 2009 1:27 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, August 11, 2014 2:21 PM
Points: 136, Visits: 1,240
I do not.

I have tried with three logins-

my own login domain\username
the service account-common for all boxes
the local admin

and all three give me the same home page as in the screenshot i sent.

strange right?
Post #782526
Posted Thursday, September 3, 2009 1:35 PM


SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Tuesday, July 29, 2014 8:19 AM
Points: 33, Visits: 23,402
Ahhhh.. I think I see your problem. You enabled anonymous authentication. It is not recommended that you enable this.

Disable that.
Apply the settings and then be sure you log in as a local admin. Navigate to http://localhost/reports

Attached is a screenshot of my settings they are "out of the box" and should work fine for now. If you want to go back in and change it later on, then great, but I think you are trying to load it for the first time right?



Brian K. McDonald, MCDBA, MCSD
Business Intelligence Consultant
Jacksonville, Florida


  Post Attachments 
IIS Security.JPG (84 views, 36.57 KB)
Post #782528
Posted Thursday, September 3, 2009 2:05 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, August 11, 2014 2:21 PM
Points: 136, Visits: 1,240
You were spot on! about the annonymous authent settings, however even after unchecking that it still does not load with all tabs .

I deleted all cookies, temp internet files , cleared the cache ---then unchecked the box again..logged out and logged back in as the local admin. It still loaded with the home page with the same almost blank homepage!
Post #782545
Posted Thursday, September 3, 2009 4:36 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Monday, August 11, 2014 2:21 PM
Points: 136, Visits: 1,240
Could this be related, when i goto inetmgr--->IIS--->open the website, i get a message saying that windows cannot find the path specified( for reportserver and report directories). It does however appear later when i click OK.

I ahve attached screenshots


  Post Attachments 
IIS1.png (68 views, 34.62 KB)
IIS2.png (48 views, 20.00 KB)
Post #782616
« Prev Topic | Next Topic »

Add to briefcase 123»»»

Permissions Expand / Collapse