Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

I create new Subscriber and getting error The row was not found at the Subscriber when applying the replicated command. Expand / Collapse
Author
Message
Posted Thursday, August 20, 2009 8:29 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, September 1, 2010 7:44 AM
Points: 176, Visits: 290
One of my Subscriber is running fine, but when I create new Subscriber I am getting following error

The row was not found at the Subscriber when applying the replicated command.
Post #774258
Posted Thursday, August 20, 2009 8:45 AM


SSC-Dedicated

SSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-Dedicated

Group: Administrators
Last Login: Today @ 2:28 PM
Points: 33,062, Visits: 15,174
Did you apply a snapshop to initialize the new subscriber?






Follow me on Twitter: @way0utwest

Forum Etiquette: How to post data/code on a forum to get the best help
Post #774279
Posted Thursday, August 20, 2009 8:52 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, September 1, 2010 7:44 AM
Points: 176, Visits: 290
No, do I have to initialize that, I restore the last night data and just create a subscriber with out initialize.
Post #774290
Posted Thursday, August 20, 2009 9:03 AM


SSC-Dedicated

SSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-Dedicated

Group: Administrators
Last Login: Today @ 2:28 PM
Points: 33,062, Visits: 15,174
You might need to if the tables in the article might have changed.

When you set up the subscriber, it ought to ask to initialize the subscriber.







Follow me on Twitter: @way0utwest

Forum Etiquette: How to post data/code on a forum to get the best help
Post #774301
Posted Thursday, August 20, 2009 9:20 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, September 1, 2010 7:44 AM
Points: 176, Visits: 290
hi I recreate the subscriber with initianilaze, now I am getting following error

The initial snapshot for publication 'OLTP_PUB_ALL_Tables' is not yet available.

also when I check the properties of Subscriber I can see Subscriber Status is "Pending"
Post #774316
Posted Thursday, August 20, 2009 9:39 AM
Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Thursday, July 17, 2014 12:34 PM
Points: 1,414, Visits: 4,539
on the subscription reinitialize it. then start it manually to make sure you get the message that the snapshot is not available.

run the snapshot

run the log reader

start the subscription and it should start copying the snapshot and then any transactions that happened during the snapshot copy


https://plus.google.com/100125998302068852885/posts?hl=en
http://twitter.com/alent1234
x-box live gamertag: i am null
[url=http://live.xbox.com/en-US/MyXbox/Profile[/url]
Post #774332
Posted Thursday, August 20, 2009 9:43 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, September 1, 2010 7:44 AM
Points: 176, Visits: 290
How to run the log reader
Post #774339
Posted Thursday, August 20, 2009 9:48 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, September 1, 2010 7:44 AM
Points: 176, Visits: 290
Hi I am getting following error, when I pick up the option initinalize

The initial snapshot for publication 'OLTP_PUB_ALL_Tables' is not yet available.
Post #774347
Posted Thursday, August 20, 2009 9:48 AM


SSCrazy

SSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazySSCrazy

Group: General Forum Members
Last Login: Sunday, July 6, 2014 3:07 PM
Points: 2,242, Visits: 3,643
MAK (8/20/2009)
How to run the log reader


If you're using pull subscription, the log reader job would be created on the subscriber, if you've setup push subscription, the job will be created on the distributor.
expand sql server agent>expand jobs> the job names with two numbers seperated by a hyphen would be your log reader agent job.





Pradeep Singh
Post #774348
Posted Thursday, August 20, 2009 10:01 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Wednesday, September 1, 2010 7:44 AM
Points: 176, Visits: 290
Hi Thansk for help,

I am still getting following error

I am getting following error, when I pick up the option initinalize

The initial snapshot for publication 'OLTP_PUB_ALL_Tables' is not yet available.
Post #774358
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse