Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Problem with linked server Expand / Collapse
Author
Message
Posted Thursday, June 11, 2009 2:52 AM


SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: 2 days ago @ 4:48 AM
Points: 946, Visits: 2,531
Hi,

I'm using linked server to SSAS that running on same machine.
usually the linked server is working just fine, but from time to time I get this error:

Cannot create an instance of OLE DB provider "MSOLAP" for linked server "SALES_CUBE". (Microsoft SQL Server, Error: 7302)

restarting the SQL fix the problem till the next time.
Any suggestions?


Kupy
Post #732835
Posted Monday, June 15, 2009 12:58 AM


SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: 2 days ago @ 4:48 AM
Points: 946, Visits: 2,531
Post #734817
Posted Thursday, July 16, 2009 11:56 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Thursday, January 20, 2011 12:35 AM
Points: 2, Visits: 20
Hi all,

i am also facing the same problem..

when i moved script for linked server creation from dev touat enviroment , after changing the server name as per uat script runs but when i try to check the connection it says "Cannot create an instance of OLE DB provider "MSOLAP" for linked server " please helpme if any one has a solution to this problem.
Post #754629
Posted Friday, July 17, 2009 2:22 AM
UDP Broadcaster

UDP BroadcasterUDP BroadcasterUDP BroadcasterUDP BroadcasterUDP BroadcasterUDP BroadcasterUDP BroadcasterUDP Broadcaster

Group: General Forum Members
Last Login: Tuesday, April 15, 2014 3:14 AM
Points: 1,487, Visits: 1,687
Have you tried setting the AllowInProcess property for the provider you are using

EXEC master.dbo.sp_MSset_oledb_prop N'xxxPROVIDERxxx', N'AllowInProcess', 1

or

Server Objects | Linked Servers | Providers | Right-click on a provider, and select Properties. Enable the Allow InProcess property.

TEST IT FIRST!!!
Post #754676
Posted Tuesday, July 28, 2009 12:30 AM


SSC Eights!

SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!SSC Eights!

Group: General Forum Members
Last Login: 2 days ago @ 4:48 AM
Points: 946, Visits: 2,531
Hi,

Sorry for the late response, at my case the Allow InProcess was enabled on creation.
Post #760537
Posted Sunday, March 20, 2011 9:00 PM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Yesterday @ 1:10 PM
Points: 111, Visits: 688
got any resolution for this..i am also facing this issue from long time back pls suggest resolution.
Post #1081064
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse