Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase

Sql Server Full-Text catalog/index is empty Expand / Collapse
Author
Message
Posted Thursday, April 16, 2009 5:10 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Monday, March 25, 2013 11:10 PM
Points: 73, Visits: 70
Hi

I am working on SQL Express 2005 with advanced services which includes full text search. I am using Full-Text catalogs and indexes. Yesterday I created full text catalog and indexes and I was able to perform various full text search queries on the table which had full text index.

But the requirements changed and I had to remove the existing full-text index and catalogs, I recreated the catalog and index on a text column, but I am not getting any results for full-text queries even though they have the keywords for which i am making a full-text search. The query "SELECT fulltextcatalogproperty('catalogname', 'ItemCount');" shows 0 as it's output which means that the full text catalog and index are not getting populated.

Please help in case anyone know on how I can resolve this issue. I even tried using the following commands:
ALTER FULLTEXT INDEX ON START FULL POPULATION;

But it says that the full population is active. Your reply will be greatly appreciated.

Regards


Best Regards
solidroots
Post #698295
Posted Thursday, April 16, 2009 7:35 AM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Saturday, August 9, 2014 9:17 AM
Points: 3,433, Visits: 14,427
I hope you actually installed it because this feature is not automatic but you said you have used it so the service maybe off in configuration manager turn it on because in the Express and Developer edition most features are turned off by default.

Kind regards,
Gift Peddie
Post #698413
Posted Thursday, April 16, 2009 8:47 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Monday, March 25, 2013 11:10 PM
Points: 73, Visits: 70
The Full text service associated with the sql server is on. I even restrated it in my attemts. Also since I was able to use full text services yesterday there is no point that it is not installed. I know that this service does not come included with the basic express edition, but I had installed this service and had used it and it was working fine.

I checked one of the log files and one of the recent entries in it said:
health monitor reported a failure for full text catalog that is associated with the database.

Thanks for your reply:
Regards
solidroots


Best Regards
solidroots
Post #698535
Posted Thursday, April 16, 2009 9:07 AM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Saturday, August 9, 2014 9:17 AM
Points: 3,433, Visits: 14,427
Then drop it and create a new one this time make sure auto populating option is used. This will show if something is wrong with your install. I have found the blog post which covers known issues with installs and some configuration you need.

http://rpsetzer.wordpress.com/2007/01/24/configuring-and-using-full-text-search-in-sql-server-2005-express-edition/



Kind regards,
Gift Peddie
Post #698563
Posted Friday, April 17, 2009 1:04 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Monday, March 25, 2013 11:10 PM
Points: 73, Visits: 70
Gift Peddie (4/16/2009)
Then drop it and create a new one this time make sure auto populating option is used. This will show if something is wrong with your install. I have found the blog post which covers known issues with installs and some configuration you need.

http://rpsetzer.wordpress.com/2007/01/24/configuring-and-using-full-text-search-in-sql-server-2005-express-edition/



Hi Peddie,

Thanks for your reply. I have dropped the existing full text index and catalog, and recreated it. This time I changed the data type of the column on which I need full-text indexing feature to varchar instead of text. And it worked fine by populating the index properly. However when i make a change to any data of this column, then the index is not re populated with new values. Of course I used "WITH CHANGE_TRACKING AUTO" while creating the full-text index. But once I manually repopulate the index by using the command "ALTER FULLTEXT INDEX ON tablename START UPDATE POPULATION;" . The index is updated.

When I check the error log of sql after using the update command it says:

Error '0x80004005' occurred during full-text index population for table or indexed view '[databasename].[dbo].[tablename]' (table or indexed view ID '1268199568', database ID '5'), full-text key value 0x00000053. Attempt will be made to reindex it.

The component 'sqlfth90.dll' reported error while indexing. Component path 'C:\Program Files\Microsoft SQL Server\90\COM\sqlfth90.dll'.


This is a very frustrating issue. I hope I will be able to come up with the solution by help from you guys.

Thanks
Best Regards
solidroots


Best Regards
solidroots
Post #699147
Posted Friday, April 17, 2009 12:19 PM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Saturday, August 9, 2014 9:17 AM
Points: 3,433, Visits: 14,427
If you don't have SP3 you need to install it and if you are using PDF column that maybe the issue because Full Text have problems with PDF from 2000. Here is some information about this error. You should know in Express Advanced SP3 is new install with SP3.

http://milambda.blogspot.com/2005_12_01_archive.html



Kind regards,
Gift Peddie
Post #699686
Posted Monday, April 20, 2009 8:39 AM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Monday, March 25, 2013 11:10 PM
Points: 73, Visits: 70
I was able to correct this behavior by allowing Remote connections on sql server. But I am not sure on why and how these things are connected.



Best Regards
solidroots
Post #700674
Posted Monday, April 20, 2009 8:49 AM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: Saturday, August 9, 2014 9:17 AM
Points: 3,433, Visits: 14,427
That could be related to the fact that most features in SQL Server Express and Developer edition are disabled by default. And the SQL Server team removed full text but a developer added the dll and was able to use it so the developer division which uses Express added full text back in the Advanced features. Good to know it is running now.



Kind regards,
Gift Peddie
Post #700684
« Prev Topic | Next Topic »

Add to briefcase

Permissions Expand / Collapse