Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

Can't Update Build on SQL 2000 SP4 Expand / Collapse
Author
Message
Posted Tuesday, December 2, 2008 8:15 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, December 5, 2008 12:31 PM
Points: 7, Visits: 27
We have a handful of servers running SQL 2000 on Windows 2000 SP4. Just recently we installed SP4 on the SQL Servers and are now running build 8.00.2050. However we ran into an issue with one of the applications that appears to have the issue fixed with build SQL Server 2000 build 8.00.2145 (KB 901212).

FIX: You receive an error message if you use the sp_addalias or sp_dropalias procedures when the IMPLICIT_TRANSACTIONS option is set to ON in SQL Server 2000 Service Pack 4


I have downloaded the hotfix from Microsoft that is to address this issue. However it does not appear that I can apply this update because it thinks it has a newer build on it. When I try to install the hotfix I am unable to select any updates and have the following messages:

File Name: SQL2000-KB903086-v8.00.2148-x86x64-ENU

Messages: This SQL Server instance you are currently running already contains the update you are trying to install. You do not need to install the update. A Hotfix of build equal to or greater than the following should be downloaded: 2273

I am not a SQL admin so I am trying to learn this as I go along. Any advice on how to patch the server to at least build 2148 would be greatly appreciated.
Post #612095
Posted Tuesday, December 2, 2008 12:59 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, December 5, 2008 12:31 PM
Points: 7, Visits: 27
I think I have found the problem...at least I can recreate it. I took a VM and installed SQL 2000 and ran SP4. I am running version 2039 as expected. So I was trying to figure out where 2050 was coming from and I figured that it was being pushed from our internal WSUS box. Sure enough I can install Hotfix build 2148 ontop of SP4 without any issues. I then tried to remove Hotfix 2148, reboot the server, and then apply Hotfix build 2050 manually. Then I tried to apply Hotfix update 2148 and I have the same issue as I described above. It looks like the update that is being pushed from our WSUS server KB948110 Hotfix update 2050 to any SQL 2000 server is causing an issue. Has anyone had this problem before?
Post #612343
Posted Tuesday, December 2, 2008 2:29 PM
SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Yesterday @ 1:50 PM
Points: 5,974, Visits: 12,877
I have not come across the problem but think I can take an educated guess at the cause and way round it. The update being applied by WSUS (god bless it) is security hotfix MS08-040, see this link

http://www.microsoft.com/technet/security/bulletin/ms08-040.mspx

and in particular the FAQ section.

Hotfix 2148 does not include this security patch that for you has been directly applied to SP4, so you need to apply the QFE update of MS08-040 post patch level 2050, which will bring you up to to 2273 and include the 2148 hotfixes you require. So you need to download the contents of KB948111 from

http://www.microsoft.com/downloads/details.aspx?familyid=8316BC5E-8C2D-4710-8ACC-B815CCC81CD4&displaylang=en

Thats my take on it anyway and I hope I explained that clearly!


---------------------------------------------------------------------

Post #612400
Posted Wednesday, December 3, 2008 10:04 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, December 5, 2008 12:31 PM
Points: 7, Visits: 27


I downloaded the update suggested above and applied it to my VM. It was able to update. We are going to put this on a production box later today and this should resovle our problem. Thank you for all your help.
Post #612998
Posted Wednesday, December 3, 2008 10:14 AM
SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Yesterday @ 1:50 PM
Points: 5,974, Visits: 12,877
thats good to hear, were you able to confirm it resolves your problem on the VM box?

---------------------------------------------------------------------

Post #613008
Posted Wednesday, December 3, 2008 5:16 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, December 5, 2008 12:31 PM
Points: 7, Visits: 27
The issue still does not appear to be resovled. After doing additional research I want to see if I understand this correct:

KB948111 which is the patch I applied is only going to install updates 8.00.2148-8.00.2272. (I have gathered this from reading another post and what is stated in the FAQ on for KB948111)


http://www.microsoft.com/technet/security/Bulletin/MS08-040.mspx


I believe the Hotfix that I need is for SQL Server 2000 build 8.00.2145 (901212 (http://support.microsoft.com/kb/901212/ ) FIX: You receive an error message if you use the sp_addalias or sp_dropalias procedures when the IMPLICIT_TRANSACTIONS option is set to ON in SQL Server 2000 Service Pack 4

http://support.microsoft.com/kb/894905/

KB948110 had installed by WSUS which patched it to build 8.00.2250 but it would not allow me to install the HOTFIX for build 8.00.2145 when the update was already installed.

So do I need to remove the HOTFIX for KB948111 which should take it back to 8.00.2050. Then reboot the server. Next unstall HOTFIX taht will take it to build 8.00.2145 (KB901212). Reboot the server if needed and then install KB948111 which should take it back to build 8.00.2272 but will include the fixes in 8.00.2145.

I hope this makes sense.
Post #613301
Posted Wednesday, December 3, 2008 5:22 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, December 5, 2008 12:31 PM
Points: 7, Visits: 27
I noticed I may need a correction on this:

So do I need to remove the HOTFIX for KB948111 which should take it back to 8.00.2050. Then reboot the server. Next unstall HOTFIX that was applied from WSUS and it will take it to build 8.00.2039 which should be straight SP4. Then install the update to take it to build 8.00.2145. Reboot the server if needed and then install KB948111 which should take it back to build 8.00.2272 but will include the fixes in 8.00.2145.

I hope this makes sense.
Post #613304
Posted Thursday, December 4, 2008 3:13 AM
SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Yesterday @ 1:50 PM
Points: 5,974, Visits: 12,877
I would need to test this to confirm which will take a while, so please do your uninstalls etc on your test box first!

One clarification, once you are at straight SP4 (2039), apply the cumulative hotfix rollup 2187 next, this definitely will contain previous HFs like 2145, then apply security patch to bring you up to 2273.

I wish microsoft would not muddy the waters like this, you used to be able to rely on hotfixs being cumulative, now there are different routes to various patch numbers and this happens.


---------------------------------------------------------------------

Post #613516
Posted Thursday, December 4, 2008 4:27 AM
SSCertifiable

SSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiableSSCertifiable

Group: General Forum Members
Last Login: Yesterday @ 1:50 PM
Points: 5,974, Visits: 12,877
mstoffa,

I went through the process as described , applying hf2187 and then 2273, but still get an error running an addalias.

have you proved that adding the hotfix for 2145 only fixes this problem?


---------------------------------------------------------------------

Post #613538
Posted Thursday, December 4, 2008 11:35 AM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Friday, December 5, 2008 12:31 PM
Points: 7, Visits: 27
I am currently working with our Dataprocessing Department on this with real data in my VM and have additional testing to do but have come up with the following so far:

1: Load SP4 and it brakes the application
2: Don't install the Update from WSUS and install the Hotfix that is to correct the issue. I had them test the application and it worked
3: Pulled all curent updates from WSUS which put it at build 2273: Broke the application again.
Post #613966
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse