Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

Error: Server local connection provider has stopped listening on [ \\.\pipe\SQLLocal\MSSQLSERVER ] Expand / Collapse
Author
Message
Posted Thursday, October 9, 2008 4:04 PM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Wednesday, July 23, 2014 6:14 PM
Points: 31, Visits: 388
I am occasionally seeing the following error on two of our SQL 2005 64bit servers. (build 9.0.3239)

"Server local connection provider has stopped listening on [ \\.\pipe\SQLLocal\MSSQLSERVER ] due to a failure. Error: 0xe8, state: 4. The server will automatically attempt to re-establish listening."

The "automatic re-establish" works within a minute and the servers seem to continue to function correctly, but I'm still interested in knowing what's causing the error.

There isn't anything in the server Event logs and there is minimal load on the server at the time.

Anyone seen anything like this before? I've had a look on the web but can't see much about it.


Cheers
Post #583633
Posted Sunday, November 16, 2008 8:48 PM
Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Monday, July 21, 2014 12:10 PM
Points: 339, Visits: 788
I'm seeing the same issues. Anyone know what might cause this?

SQL Ver 9.0.3186
Post #603430
Posted Monday, December 29, 2008 2:44 PM
Valued Member

Valued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued MemberValued Member

Group: General Forum Members
Last Login: Wednesday, June 11, 2014 8:19 AM
Points: 54, Visits: 337
I am having the same problem. Please let me know, why it is happening.
Post #626854
Posted Monday, December 29, 2008 10:03 PM


Old Hand

Old HandOld HandOld HandOld HandOld HandOld HandOld HandOld Hand

Group: General Forum Members
Last Login: Tuesday, June 18, 2013 7:41 AM
Points: 323, Visits: 464
Spicoli (10/9/2008)
I am occasionally seeing the following error on two of our SQL 2005 64bit servers. (build 9.0.3239)

"Server local connection provider has stopped listening on [ \\.\pipe\SQLLocal\MSSQLSERVER ] due to a failure. Error: 0xe8, state: 4. The server will automatically attempt to re-establish listening."

The "automatic re-establish" works within a minute and the servers seem to continue to function correctly, but I'm still interested in knowing what's causing the error.

There isn't anything in the server Event logs and there is minimal load on the server at the time.

Anyone seen anything like this before? I've had a look on the web but can't see much about it.


Cheers


Please enable named piped protcol in sql server.


_____________________________________________________________________________________________________________
Paresh Prajapati
+919924626601
http://paresh-sqldba.blogspot.com/
LinkedIn | Tweet Me | FaceBook | Brijj
Post #627007
Posted Thursday, April 2, 2009 12:50 PM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, March 11, 2011 12:41 PM
Points: 37, Visits: 67
Paresh,
I am recieving the same erroe as stated above. The solution you've suggested is to enable 'named pipes' in the config manager. I have crosschecked that the 'named pipes' is already enabled on the server that keeps sending out the error, ie., "Error: 0xe8, state: 4". Any suggestions ?

Thanks,
SP
Post #689258
Posted Thursday, April 2, 2009 1:17 PM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: 2 days ago @ 12:12 AM
Points: 3,433, Visits: 14,422
Do you see any issue with this behavior? It looks like a client made a NP connection to the server after the Pipe is created, but before it's ready to accept connection. When we try to setup things to accept connection, we could re-active the existing client connection and thing would be OK. However, looks like in your case, client closed the connection before everything is ready and we logged this error. The server is robust to create another pipe to accept new connections after this. You can verify if this is the case by using Netmon to see how the NP connection is opened/closed.


The above is the correct answer it is related to Named Pipe being used before it is ready to accept connection. Check the link below for details.


http://blogs.msdn.com/sql_protocols/archive/2005/12/22/506607.aspx


Kind regards,
Gift Peddie
Post #689277
Posted Thursday, April 2, 2009 1:47 PM
SSC Rookie

SSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC RookieSSC Rookie

Group: General Forum Members
Last Login: Friday, March 11, 2011 12:41 PM
Points: 37, Visits: 67
Thanks for the prompt reply.

Is there anyway this problem can be avoided / fixed ?
Post #689313
Posted Thursday, April 2, 2009 2:00 PM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: 2 days ago @ 12:12 AM
Points: 3,433, Visits: 14,422
You could enable Named Pipes and TCP/IP which is what I do but you also have the option to use NetMon to see how your Named Pipes are opened and closed per that text I posted.

http://blogs.technet.com/netmon/



Kind regards,
Gift Peddie
Post #689337
Posted Thursday, March 21, 2013 9:19 AM
SSC-Addicted

SSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-AddictedSSC-Addicted

Group: General Forum Members
Last Login: Wednesday, May 22, 2013 8:43 AM
Points: 442, Visits: 620
Can you tell me where to find this entry in SMS ?

"Please enable named piped protcol in sql server."

Thanks
Jim
Post #1433858
Posted Thursday, March 21, 2013 9:39 AM
Hall of Fame

Hall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of FameHall of Fame

Group: General Forum Members
Last Login: 2 days ago @ 12:12 AM
Points: 3,433, Visits: 14,422
JC-3113 (3/21/2013)
Can you tell me where to find this entry in SMS ?

"Please enable named piped protcol in sql server."

Thanks
Jim


The protocols are not in SMS but in Configuration manager under Network Configuration then Protocols. I am only running SQL Server 2012 so I am assuming it is the same in 2005.



Kind regards,
Gift Peddie
Post #1433872
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse