Click here to monitor SSC
SQLServerCentral is supported by Red Gate Software Ltd.
 
Log in  ::  Register  ::  Not logged in
 
 
 
        
Home       Members    Calendar    Who's On


Add to briefcase 12»»

Microsoft SQL Server, Error : 2 Expand / Collapse
Author
Message
Posted Tuesday, September 23, 2008 6:15 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Thursday, February 21, 2013 6:18 AM
Points: 120, Visits: 108
While connecting to SQL Server 2005, I am getting the following error.

"An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (Provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)"

I restarted the Server and then tried to connect to SQL Server, it is allowing me to connect. Whenever the problem comes, I am restarting the server. But I want the actual solution for this problem.

Can anybody help me out in solving this issue.
Post #574247
Posted Tuesday, September 23, 2008 9:38 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Thursday, December 6, 2012 2:49 PM
Points: 140, Visits: 310
are you connecting to the local server or remote server?
connecting using windows login/sqlserver login?
Post #574551
Posted Sunday, September 28, 2008 9:48 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Thursday, February 21, 2013 6:18 AM
Points: 120, Visits: 108

Yes, I am connecting to a local server.

Using SQL Server Authentication.

Post #577433
Posted Monday, September 29, 2008 5:09 AM
SSC-Enthusiastic

SSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-EnthusiasticSSC-Enthusiastic

Group: General Forum Members
Last Login: Thursday, December 6, 2012 2:49 PM
Points: 140, Visits: 310
Check if all the Services are running in sql server configuration manager
check the protocols if they are enabled.

You sometimes get the same error, when you have entered a wrong userid/pwd.
Post #577627
Posted Sunday, March 15, 2009 12:13 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Monday, May 4, 2009 3:58 PM
Points: 3, Visits: 4
hi,
im getting the same error but im using windows authentication - any suggestions? Thanks :o)
Post #676150
Posted Sunday, March 15, 2009 8:24 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Monday, May 4, 2009 3:58 PM
Points: 3, Visits: 4
no worries, managed to solve it myself. basically i made sure all services were running as previously posted, and then, funnily enough, running SQL Server Management Studio as administrator did the trick!

Thanks anyways :o)
Post #676215
Posted Sunday, March 15, 2009 8:58 PM


SSC-Dedicated

SSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-DedicatedSSC-Dedicated

Group: Administrators
Last Login: Today @ 11:32 AM
Points: 33,275, Visits: 15,444
Administrator shouldn't matter, it's the accounts that are set up in SQL Server. Likely the local administrator's group is set up as a login in SQL.






Follow me on Twitter: @way0utwest

Forum Etiquette: How to post data/code on a forum to get the best help
Post #676219
Posted Thursday, August 26, 2010 11:40 PM
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Group: General Forum Members
Last Login: Saturday, March 5, 2011 11:29 PM
Points: 3, Visits: 6
are you sure you have use the correct username and choose the right instance?
the instance should be like this : server name/instance
your username should be like this if you use windows au :server name /username
Post #976156
Posted Friday, September 17, 2010 10:51 AM


Ten Centuries

Ten CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen CenturiesTen Centuries

Group: General Forum Members
Last Login: Tuesday, June 10, 2014 6:14 AM
Points: 1,200, Visits: 3,237
@ sundaram

Choose the mixed mode of authentication

Windows and the sql server

Regards
Sushant
Post #988410
Posted Friday, September 17, 2010 11:08 AM


SSC-Forever

SSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-ForeverSSC-Forever

Group: General Forum Members
Last Login: Today @ 7:57 AM
Points: 43,045, Visits: 36,205
Please note: 2 year old thread.


Gail Shaw
Microsoft Certified Master: SQL Server 2008, MVP
SQL In The Wild: Discussions on DB performance with occasional diversions into recoverability

We walk in the dark places no others will enter
We stand on the bridge and no one may pass

Post #988431
« Prev Topic | Next Topic »

Add to briefcase 12»»

Permissions Expand / Collapse